summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2006-03-25 15:20:19 +0000
committerFabian Groffen <grobian@gentoo.org>2006-03-25 15:20:19 +0000
commit08e931c03c7820e93f7b25db296068ac7f3001ab (patch)
treeb214adb57ee0b96e04c2c6d8474a8a980c1386a6 /gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.10.3.ebuild
parentMasking =gnustep-base/gnustep-base-1.12.0, it causes sandbox violations (diff)
downloadhistorical-08e931c03c7820e93f7b25db296068ac7f3001ab.tar.gz
historical-08e931c03c7820e93f7b25db296068ac7f3001ab.tar.bz2
historical-08e931c03c7820e93f7b25db296068ac7f3001ab.zip
Removing ald and masked files, bumping version, ported to modular X.
Package-Manager: portage-2.1_pre6-r5
Diffstat (limited to 'gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.10.3.ebuild')
-rw-r--r--gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.10.3.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.10.3.ebuild b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.10.3.ebuild
new file mode 100644
index 000000000000..1b31d985189c
--- /dev/null
+++ b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.10.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.10.3.ebuild,v 1.1 2006/03/25 15:20:19 grobian Exp $
+
+inherit gnustep
+
+S=${WORKDIR}/gnustep-back-${PV}
+
+DESCRIPTION="Default X11 back-end component for the GNUstep GUI Library"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+PROVIDE="virtual/gnustep-back"
+
+IUSE="opengl xim"
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-make-1.10
+ >=gnustep-base/gnustep-base-1.10
+ ~gnustep-base/gnustep-gui-0.10.3
+ opengl? ( virtual/opengl virtual/glu )
+ || (
+ (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXft
+ x11-libs/libXrender
+ )
+ virtual/x11
+ )
+ dev-libs/expat
+ media-libs/fontconfig
+ >=media-libs/freetype-2.1.9
+ !virtual/gnustep-back"
+RDEPEND="${DEPEND}
+ ${DEBUG_DEPEND}
+ ${DOC_RDEPEND}"
+
+egnustep_install_domain "System"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ EPATCH_OPTS="-d ${S}" epatch "${FILESDIR}/font-make-fix.patch-${PV}"
+}
+
+src_compile() {
+ egnustep_env
+
+ use opengl && myconf="--enable-glx"
+ myconf="$myconf `use_enable xim`"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=xlib --with-name=xlib"
+ econf $myconf || die "configure failed"
+
+ egnustep_make
+}
+