summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-11-12 04:07:07 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-11-12 04:07:07 +0000
commit8bbe17aaa64e00238e2b891283023049dbf97af1 (patch)
tree70245750802c9b480dfd21a6e6c4aeef28fa95bc /gnustep-libs/artresources/artresources-0.1.2.ebuild
parentStable on sparc (diff)
downloadhistorical-8bbe17aaa64e00238e2b891283023049dbf97af1.tar.gz
historical-8bbe17aaa64e00238e2b891283023049dbf97af1.tar.bz2
historical-8bbe17aaa64e00238e2b891283023049dbf97af1.zip
Mass Update: gnustep.eclass revamped to allow configurable root install; gnustep-base/libs/apps updated to utilize new gnustep.eclass (only versions bumped where files would change); some KEYWORDS were accidentally dropped between version bumps of packages -- this has been resolved; windowmaker correctly supports gnustep now; gnustep-funcs.eclass added -- used where info on an installed gnustep-env is needed rather than making a full GNUstep application
Diffstat (limited to 'gnustep-libs/artresources/artresources-0.1.2.ebuild')
-rw-r--r--gnustep-libs/artresources/artresources-0.1.2.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnustep-libs/artresources/artresources-0.1.2.ebuild b/gnustep-libs/artresources/artresources-0.1.2.ebuild
index 6da80cf5df45..5e50187af5ba 100644
--- a/gnustep-libs/artresources/artresources-0.1.2.ebuild
+++ b/gnustep-libs/artresources/artresources-0.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/artresources/artresources-0.1.2.ebuild,v 1.5 2004/11/05 22:13:32 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/artresources/artresources-0.1.2.ebuild,v 1.6 2004/11/12 04:07:07 fafhrd Exp $
inherit gnustep
@@ -18,7 +18,9 @@ PROVIDES="virtual/gnustep-back"
IUSE=""
DEPEND="${GNUSTEP_GUI_DEPEND}
- =media-libs/libart_lgpl-2.3.16"
+ >=media-libs/libart_lgpl-2.3.16"
+
+egnustep_install_domain "System"
src_compile() {
echo "nothing to compile"
@@ -26,8 +28,8 @@ src_compile() {
src_install() {
egnustep_env
- dodir ${GNUSTEP_SYSTEM_ROOT}/Library/Fonts
- insinto ${GNUSTEP_SYSTEM_ROOT}/Library/Fonts
- cp -a *.nfont ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Fonts
+ dodir $(egnustep_system_root)/Library/Fonts
+ insinto $(egnustep_system_root)/Library/Fonts
+ cp -a *.nfont ${D}$(egnustep_system_root)/Library/Fonts
}