summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-12-08 18:01:38 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-12-08 18:01:38 +0000
commit04b7c83eb9a349aab65a09e4a4ecefcbdc2d3aac (patch)
tree6810f4d0af709f7f9a675f647b9642d934892a80 /gnustep-libs/gdl2/gdl2-0.11.0.ebuild
parentStable for HPPA (bug #201438). (diff)
downloadhistorical-04b7c83eb9a349aab65a09e4a4ecefcbdc2d3aac.tar.gz
historical-04b7c83eb9a349aab65a09e4a4ecefcbdc2d3aac.tar.bz2
historical-04b7c83eb9a349aab65a09e4a4ecefcbdc2d3aac.zip
Version bump, ebuild cleanup, add sqlite support
Package-Manager: portage-2.1.4_rc9
Diffstat (limited to 'gnustep-libs/gdl2/gdl2-0.11.0.ebuild')
-rw-r--r--gnustep-libs/gdl2/gdl2-0.11.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnustep-libs/gdl2/gdl2-0.11.0.ebuild b/gnustep-libs/gdl2/gdl2-0.11.0.ebuild
new file mode 100644
index 000000000000..dbab22ee1c55
--- /dev/null
+++ b/gnustep-libs/gdl2/gdl2-0.11.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/gdl2/gdl2-0.11.0.ebuild,v 1.1 2007/12/08 18:01:38 voyageur Exp $
+
+inherit gnustep-2
+
+MY_P="gnustep-dl2-${PV}"
+DESCRIPTION="GNUstep Database Library 2 (GDL2) for mapping Obj-C to RDBMSes"
+HOMEPAGE="http://www.gnustep.org/"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="postgres sqlite"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="!gnustep-apps/sope
+ postgres? ( dev-db/libpq )
+ sqlite? ( dev-db/sqlite )"
+RDEPEND="${DEPEND}"