summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
commit5dce68c9cc05b718532a522d45797435bc4d68b2 (patch)
tree3405da9ffcff7553acfd1a283d8344919ace829c /kde-base/ark
parentrename check_apache_threads to has_apache_threads as suggested by dberkholz (diff)
downloadhistorical-5dce68c9cc05b718532a522d45797435bc4d68b2.tar.gz
historical-5dce68c9cc05b718532a522d45797435bc4d68b2.tar.bz2
historical-5dce68c9cc05b718532a522d45797435bc4d68b2.zip
Version bump to KDE 4.0.1.
Package-Manager: portage-2.1.4.1
Diffstat (limited to 'kde-base/ark')
-rw-r--r--kde-base/ark/ChangeLog7
-rw-r--r--kde-base/ark/ark-4.0.1.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/kde-base/ark/ChangeLog b/kde-base/ark/ChangeLog
index 2290ea09269b..189219719632 100644
--- a/kde-base/ark/ChangeLog
+++ b/kde-base/ark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ark
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.77 2008/01/31 15:30:32 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.78 2008/02/07 00:11:48 philantrop Exp $
+
+*ark-4.0.1 (06 Feb 2008)
+
+ 06 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org> +ark-4.0.1.ebuild:
+ Version bump to KDE 4.0.1.
31 Jan 2008; Brent Baude <ranger@gentoo.org> ark-3.5.8.ebuild:
Marking ark-3.5.8 ppc for bug 207634
diff --git a/kde-base/ark/ark-4.0.1.ebuild b/kde-base/ark/ark-4.0.1.ebuild
new file mode 100644
index 000000000000..83c48525e135
--- /dev/null
+++ b/kde-base/ark/ark-4.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.0.1.ebuild,v 1.1 2008/02/07 00:11:48 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdeutils
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~x86"
+IUSE="archive debug htmlhandbook zip"
+
+COMMONDEPEND="archive? ( app-arch/libarchive )
+ zip? ( >=dev-libs/libzip-0.8 )"
+DEPEND="${DEPEND} ${COMMONDEPEND}"
+RDEPEND="${RDEPEND} ${COMMONDEPEND}"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with zip LibZip)"
+
+ kde4-meta_src_compile
+}