summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-02-07 20:00:13 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-02-07 20:00:13 +0000
commit127a5bbfd47f2b207f56bd58072c16c5e3a5c613 (patch)
treefb43f22069d2a9042d5abb1874e7cfd3dafea7de /kde-base/arts
parentChange to using get_libdir, in preperation for a fully supported amd64 mono v... (diff)
downloadhistorical-127a5bbfd47f2b207f56bd58072c16c5e3a5c613.tar.gz
historical-127a5bbfd47f2b207f56bd58072c16c5e3a5c613.tar.bz2
historical-127a5bbfd47f2b207f56bd58072c16c5e3a5c613.zip
New revision. See ChangeLog.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'kde-base/arts')
-rw-r--r--kde-base/arts/ChangeLog7
-rw-r--r--kde-base/arts/arts-1.3.2-r1.ebuild87
-rw-r--r--kde-base/arts/files/digest-arts-1.3.2-r11
3 files changed, 94 insertions, 1 deletions
diff --git a/kde-base/arts/ChangeLog b/kde-base/arts/ChangeLog
index dacb3d1a3a47..a9c2afa5ff7b 100644
--- a/kde-base/arts/ChangeLog
+++ b/kde-base/arts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/arts
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.140 2005/02/05 11:39:10 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.141 2005/02/07 19:59:15 greg_g Exp $
+
+*arts-1.3.2-r1 (07 Feb 2005)
+
+ 07 Feb 2005; Gregorio Guidi <greg_g@gentoo.org> +arts-1.3.2-r1.ebuild:
+ Remove KDEDIR form the environment (#33079).
*arts-3.4.0_beta2 (05 Feb 2005)
diff --git a/kde-base/arts/arts-1.3.2-r1.ebuild b/kde-base/arts/arts-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..95e20abf4095
--- /dev/null
+++ b/kde-base/arts/arts-1.3.2-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.3.2-r1.ebuild,v 1.1 2005/02/07 19:59:15 greg_g Exp $
+
+inherit kde flag-o-matic eutils
+set-kdedir 3.3
+
+DESCRIPTION="aRts, the KDE sound (and all-around multimedia) server/output manager"
+HOMEPAGE="http://multimedia.kde.org/"
+SRC_URI="mirror://kde/stable/${PV/1.3.2/3.3.2}/src/${PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.3"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~alpha"
+IUSE="alsa oggvorbis esd artswrappersuid jack mad hardened"
+
+DEPEND="alsa? ( media-libs/alsa-lib virtual/alsa )
+ oggvorbis? ( media-libs/libvorbis media-libs/libogg )
+ esd? ( media-sound/esound )
+ jack? ( media-sound/jack-audio-connection-kit )
+ mad? ( media-libs/libmad media-libs/libid3tag )
+ media-libs/audiofile
+ >=dev-libs/glib-2
+ >=x11-libs/qt-3.3"
+
+# patch to configure.in.in that makes the vorbis, libmad deps optional
+# has no version number in its filename because it's the same for all
+# arts versions - the patched file hasn't changed in a year's time
+# PATCHES="$FILESDIR/optional-deps.diff"
+
+src_unpack() {
+ kde_src_unpack
+ epatch ${FILESDIR}/1.3.0-jack-configure.in.in.patch
+ epatch ${FILESDIR}/${P}-alsa-bigendian.patch
+
+ if (is-flag -fstack-protector || is-flag -fstack-protector-all || use hardened); then
+ epatch ${FILESDIR}/arts-1.3.2-mcopidl.patch
+ fi
+
+ kde_sandbox_patch ${S}/soundserver
+ # for the configure.in.in patch, for some reason it's not automatically picked up
+ # rm -f $S/configure
+
+ cd ${S} && make -f admin/Makefile.common
+ # use amd64 && epatch ${FILESDIR}/arts-${PV}-buffer.patch
+ # this patch fixes the high cpu usage of mp3 and vorbis
+ # epatch ${FILESDIR}/arts-vorbis-fix.dif
+}
+
+src_compile() {
+
+ #fix bug 13453
+ filter-flags -foptimize-sibling-calls
+
+ #fix bug 41980
+ use sparc && filter-flags -fomit-frame-pointer
+
+ myconf="$myconf $(use_enable alsa) $(use_enable oggvorbis vorbis) $(use_enable mad libmad) $(use_enable jack)"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+ dodoc ${S}/doc/{NEWS,README,TODO}
+
+ # moved here from kdelibs so that when arts is installed
+ # without kdelibs it's still in the path.
+ dodir /etc/env.d
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+CONFIG_PROTECT=\"${PREFIX}/share/config ${PREFIX}/env ${PREFIX}/shutdown\"" > ${D}/etc/env.d/47kdepaths-3.3.1 # number goes down with version upgrade
+
+ # used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s ${D}/${PREFIX}/bin/artswrapper
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ einfo "Run chmod u+s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
+ einfo "and so avoid possible skips in sound. However, on untrusted systems this"
+ einfo "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ einfo "priority, and so is off by default. See bug #7883."
+ einfo "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+ fi
+}
diff --git a/kde-base/arts/files/digest-arts-1.3.2-r1 b/kde-base/arts/files/digest-arts-1.3.2-r1
new file mode 100644
index 000000000000..0c4a34c7c80d
--- /dev/null
+++ b/kde-base/arts/files/digest-arts-1.3.2-r1
@@ -0,0 +1 @@
+MD5 a3d22f7cc5c641204a28d3f77e441a84 arts-1.3.2.tar.bz2 968368