summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
commit96b2ccccbdb3a629585880f16ae065b3a046ecf8 (patch)
tree8614154608c173341cea9bbafdd085551b050be8 /kde-base/cantor
parentAdd net-misc/leechcraft-launchy, thanks to 0xd34df00d (diff)
downloadhistorical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.gz
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.bz2
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.zip
Version bump KDE SC 4.9.1
Package-Manager: portage-2.2.0_alpha124/cvs/Linux x86_64
Diffstat (limited to 'kde-base/cantor')
-rw-r--r--kde-base/cantor/ChangeLog7
-rw-r--r--kde-base/cantor/cantor-4.9.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
index df9c69e893d7..1f69dc40cabf 100644
--- a/kde-base/cantor/ChangeLog
+++ b/kde-base/cantor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/cantor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.81 2012/09/03 13:29:21 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.82 2012/09/04 18:45:45 johu Exp $
+
+*cantor-4.9.1 (04 Sep 2012)
+
+ 04 Sep 2012; Johannes Huber <johu@gentoo.org> +cantor-4.9.1.ebuild:
+ Version bump KDE SC 4.9.1
03 Sep 2012; Johannes Huber <johu@gentoo.org> -cantor-4.7.4.ebuild:
Remove KDE SC 4.7.4
diff --git a/kde-base/cantor/cantor-4.9.1.ebuild b/kde-base/cantor/cantor-4.9.1.ebuild
new file mode 100644
index 000000000000..d9dbbf959d5b
--- /dev/null
+++ b/kde-base/cantor/cantor-4.9.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.9.1.ebuild,v 1.1 2012/09/04 18:45:45 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="analitza debug postscript qalculate +R"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+ analitza? ( $(add_kdebase_dep analitza) )
+ qalculate? (
+ sci-libs/cln
+ sci-libs/libqalculate
+ )
+ postscript? ( app-text/libspectre )
+ R? ( dev-lang/R )
+ x11-libs/qt-xmlpatterns:4
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with analitza)
+ $(cmake-utils_use_with postscript LibSpectre)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with R)
+ )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use analitza && ! use qalculate && ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'analitza', 'qalculate' or 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}