summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2011-04-21 21:40:52 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2011-04-21 21:40:52 +0000
commitaf75cc0f214f2242eb685460530739309ee5fb84 (patch)
tree437530a5ceaceda8a851ac041de87dfa93fc9182 /kde-base/kabcclient/kabcclient-4.4.11.1.ebuild
parentAdd GNOME2_LA_PUNT support from the overlay. (diff)
downloadhistorical-af75cc0f214f2242eb685460530739309ee5fb84.tar.gz
historical-af75cc0f214f2242eb685460530739309ee5fb84.tar.bz2
historical-af75cc0f214f2242eb685460530739309ee5fb84.zip
Version bump
Package-Manager: portage-2.1.9.46/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kabcclient/kabcclient-4.4.11.1.ebuild')
-rw-r--r--kde-base/kabcclient/kabcclient-4.4.11.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/kabcclient/kabcclient-4.4.11.1.ebuild b/kde-base/kabcclient/kabcclient-4.4.11.1.ebuild
new file mode 100644
index 000000000000..0e66ee05c94e
--- /dev/null
+++ b/kde-base/kabcclient/kabcclient-4.4.11.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kabcclient/kabcclient-4.4.11.1.ebuild,v 1.1 2011/04/21 21:11:58 dilfridge Exp $
+
+EAPI=4
+
+KDE_MINIMAL="4.6"
+KMNAME="kdepim"
+KMMODULE="console/${PN}"
+inherit kde4-meta
+
+DESCRIPTION="A command line client for accessing the KDE addressbook"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ kde4-meta_src_install
+
+ # work around NULL DT_RPATH in kabc2mutt
+ dosym kabcclient ${PREFIX}/bin/kabc2mutt || die "couldn't symlink kabc2mutt to kabcclient"
+}