summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-01 20:22:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-01 20:22:21 +0000
commit7a13232fed5821d39c0af7a4a351b0fe5f0a8a84 (patch)
tree1636d3235a911920ce7e9dcf34d08798f846fff5 /kde-base/kaddressbook
parentUpdate to new release. (diff)
downloadhistorical-7a13232fed5821d39c0af7a4a351b0fe5f0a8a84.tar.gz
historical-7a13232fed5821d39c0af7a4a351b0fe5f0a8a84.tar.bz2
historical-7a13232fed5821d39c0af7a4a351b0fe5f0a8a84.zip
Update to new release.
Package-Manager: portage-2.1_rc3-r3
Diffstat (limited to 'kde-base/kaddressbook')
-rw-r--r--kde-base/kaddressbook/ChangeLog8
-rw-r--r--kde-base/kaddressbook/files/digest-kaddressbook-3.5.33
-rw-r--r--kde-base/kaddressbook/kaddressbook-3.5.3.ebuild54
3 files changed, 64 insertions, 1 deletions
diff --git a/kde-base/kaddressbook/ChangeLog b/kde-base/kaddressbook/ChangeLog
index bfb7c1ce8a8d..b403b7338ebf 100644
--- a/kde-base/kaddressbook/ChangeLog
+++ b/kde-base/kaddressbook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kaddressbook
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.50 2006/06/01 05:29:24 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/ChangeLog,v 1.51 2006/06/01 16:41:58 flameeyes Exp $
+
+*kaddressbook-3.5.3 (01 Jun 2006)
+
+ 01 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +kaddressbook-3.5.3.ebuild:
+ Update to new release.
01 Jun 2006; Thomas Cort <tcort@gentoo.org> kaddressbook-3.5.2-r1.ebuild:
Stable on alpha wrt Bug #132213.
diff --git a/kde-base/kaddressbook/files/digest-kaddressbook-3.5.3 b/kde-base/kaddressbook/files/digest-kaddressbook-3.5.3
new file mode 100644
index 000000000000..c275327d50af
--- /dev/null
+++ b/kde-base/kaddressbook/files/digest-kaddressbook-3.5.3
@@ -0,0 +1,3 @@
+MD5 2b83885854a5953bca59508d9a7cf5ef kdepim-3.5.3.tar.bz2 12912017
+RMD160 fdd951d6c117246f170986d944d3d61c094e9a00 kdepim-3.5.3.tar.bz2 12912017
+SHA256 460f9104c63c8a57801f5405be7c709e8604abf93c7f35ee9d60d20e0e0e5adb kdepim-3.5.3.tar.bz2 12912017
diff --git a/kde-base/kaddressbook/kaddressbook-3.5.3.ebuild b/kde-base/kaddressbook/kaddressbook-3.5.3.ebuild
new file mode 100644
index 000000000000..047fed186403
--- /dev/null
+++ b/kde-base/kaddressbook/kaddressbook-3.5.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-3.5.3.ebuild,v 1.1 2006/06/01 16:41:58 flameeyes Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE Address Book"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gnokii"
+DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/certmanager)
+$(deprange $PV $MAXKDEVER kde-base/libkdenetwork)
+$(deprange $PV $MAXKDEVER kde-base/kontact)
+gnokii? ( app-mobilephone/gnokii )"
+
+myconf="$myconf $(use_with gnokii)"
+
+KMCOPYLIB="
+ libkdepim libkdepim
+ libkcal libkcal
+ libkleopatra certmanager/lib/
+ libqgpgme libkdenetwork/qgpgme/
+ libkpinterfaces kontact/interfaces/"
+KMEXTRACTONLY="
+ libkdepim/
+ libkdenetwork/
+ libkcal/
+ certmanager/
+ kontact/interfaces/
+ akregator
+ kmail/kmailIface.h"
+KMCOMPILEONLY="
+ libkcal/libical/src/libical/
+ libkcal/libical/src/libicalss/
+ akregator/src/librss"
+ # We add them here because they are standard plugins and programs related to kaddressbook but not a dep of any other kdepim program, so they will be lost if noone install them
+KMEXTRA="
+ kabc/
+ kfile-plugins/vcf
+ kontact/plugins/kaddressbook"
+
+src_compile() {
+ export DO_NOT_COMPILE="libical" && kde-meta_src_compile myconf configure
+ # generate "ical.h"
+ cd ${S}/libkcal/libical/src/libical && make ical.h
+ # generate "icalss.h"
+ cd ${S}/libkcal/libical/src/libicalss && make icalss.h
+
+ kde-meta_src_compile "make"
+}