summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2008-09-14 00:00:42 +0000
committerCarsten Lohrke <carlo@gentoo.org>2008-09-14 00:00:42 +0000
commitb974b6ef740bd72ca318243730adf05a46a3ac13 (patch)
tree83960462b16e9bb431666835e4b3d90f67f1c45c /kde-base/kbabel/kbabel-3.5.10.ebuild
parentVersion bump and include patch to support Audacious 1.5. (diff)
downloadhistorical-b974b6ef740bd72ca318243730adf05a46a3ac13.tar.gz
historical-b974b6ef740bd72ca318243730adf05a46a3ac13.tar.bz2
historical-b974b6ef740bd72ca318243730adf05a46a3ac13.zip
Version bump.
Diffstat (limited to 'kde-base/kbabel/kbabel-3.5.10.ebuild')
-rw-r--r--kde-base/kbabel/kbabel-3.5.10.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/kbabel/kbabel-3.5.10.ebuild b/kde-base/kbabel/kbabel-3.5.10.ebuild
new file mode 100644
index 000000000000..bd5a1666883b
--- /dev/null
+++ b/kde-base/kbabel/kbabel-3.5.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kbabel/kbabel-3.5.10.ebuild,v 1.1 2008/09/13 23:57:30 carlo Exp $
+
+KMNAME=kdesdk
+EAPI="1"
+inherit db-use kde-meta eutils
+
+DESCRIPTION="KBabel - An advanced PO file editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb kdehiddenvisibility"
+
+DEPEND="berkdb? ( =sys-libs/db-4* )"
+
+src_compile() {
+ local myconf=""
+
+ if use berkdb; then
+ myconf="${myconf} --with-berkeley-db --with-db-lib=$(db_libname)
+ --with-extra-includes=$(db_includedir)"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ kde_src_compile
+}