summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
commit6f430e346de22377dc53caf57d7a8b62b57eb7ed (patch)
tree7bf86d97cf974dfed6c010d3ff5aebc192229757 /kde-base/kcheckpass
parentRemoved unneccessary python_copy_sources (diff)
downloadhistorical-6f430e346de22377dc53caf57d7a8b62b57eb7ed.tar.gz
historical-6f430e346de22377dc53caf57d7a8b62b57eb7ed.tar.bz2
historical-6f430e346de22377dc53caf57d7a8b62b57eb7ed.zip
[kde-base] Add KDE SC 4.6.1
Package-Manager: portage-2.2.0_alpha26/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.6.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 6728a7d14f52..1caa4a5a4fbd 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.176 2011/01/26 20:28:46 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.177 2011/03/04 18:00:22 alexxy Exp $
+
+*kcheckpass-4.6.1 (04 Mar 2011)
+
+ 04 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org> +kcheckpass-4.6.1.ebuild:
+ Version bump KDE SC 4.6.1
*kcheckpass-4.6.0 (26 Jan 2011)
diff --git a/kde-base/kcheckpass/kcheckpass-4.6.1.ebuild b/kde-base/kcheckpass/kcheckpass-4.6.1.ebuild
new file mode 100644
index 000000000000..e725aa3f312c
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.6.1.ebuild,v 1.1 2011/03/04 18:00:22 alexxy Exp $
+
+EAPI=3
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+DEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/kdebase-4.0.2-pam-optional.patch"
+)
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}