summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2011-06-10 18:00:20 +0000
commit75f228d8cf8a4fb6ddf12ece4c814b78edb95850 (patch)
tree2a0735defeb822e6f238e00f6c5e3fee524d661a /kde-base/kdebindings-perl
parentSort test dep. Remove useless dies. (diff)
downloadhistorical-75f228d8cf8a4fb6ddf12ece4c814b78edb95850.tar.gz
historical-75f228d8cf8a4fb6ddf12ece4c814b78edb95850.tar.bz2
historical-75f228d8cf8a4fb6ddf12ece4c814b78edb95850.zip
Version bump
Package-Manager: portage-2.1.10/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kdebindings-perl')
-rw-r--r--kde-base/kdebindings-perl/ChangeLog8
-rw-r--r--kde-base/kdebindings-perl/kdebindings-perl-4.6.4.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/kde-base/kdebindings-perl/ChangeLog b/kde-base/kdebindings-perl/ChangeLog
index d8e5f6781173..2dfa8082db69 100644
--- a/kde-base/kdebindings-perl/ChangeLog
+++ b/kde-base/kdebindings-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebindings-perl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/ChangeLog,v 1.20 2011/06/10 11:50:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/ChangeLog,v 1.21 2011/06/10 17:59:48 dilfridge Exp $
+
+*kdebindings-perl-4.6.4 (10 Jun 2011)
+
+ 10 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kdebindings-perl-4.6.4.ebuild:
+ Version bump
10 Jun 2011; Markos Chandras <hwoarang@gentoo.org>
kdebindings-perl-4.6.3.ebuild:
diff --git a/kde-base/kdebindings-perl/kdebindings-perl-4.6.4.ebuild b/kde-base/kdebindings-perl/kdebindings-perl-4.6.4.ebuild
new file mode 100644
index 000000000000..650ec89d324f
--- /dev/null
+++ b/kde-base/kdebindings-perl/kdebindings-perl-4.6.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-perl/kdebindings-perl-4.6.4.ebuild,v 1.1 2011/06/10 17:59:48 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdebindings"
+KMMODULE="perl"
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE Perl bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi attica debug kate okular phonon plasma qimageblitz qscintilla qwt semantic-desktop webkit"
+
+DEPEND="
+ >=dev-lang/perl-5.10.1
+ $(add_kdebase_dep smoke 'akonadi?,attica?,declarative?,kate?,multimedia?,okular?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,semantic-desktop=,webkit?')
+ semantic-desktop? ( >=dev-libs/soprano-2.4.64 )
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="smoke"
+
+KMEXTRACTONLY="
+ smoke/
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-meta_src_configure
+}