summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-08-16 02:54:27 +0000
committerAchim Gottinger <achim@gentoo.org>2001-08-16 02:54:27 +0000
commit9fbf8153c9824858bda1dfb8e74101f34e2cff3a (patch)
tree52f84978fbe9b3f6944e13e4cf8af5d544113009 /kde-base/kdegraphics
parentmodified some startup paramters to add apache style log file generation. (diff)
downloadhistorical-9fbf8153c9824858bda1dfb8e74101f34e2cff3a.tar.gz
historical-9fbf8153c9824858bda1dfb8e74101f34e2cff3a.tar.bz2
historical-9fbf8153c9824858bda1dfb8e74101f34e2cff3a.zip
*** empty log message ***
Diffstat (limited to 'kde-base/kdegraphics')
-rw-r--r--kde-base/kdegraphics/files/digest-kdegraphics-2.21
-rw-r--r--kde-base/kdegraphics/kdegraphics-2.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-base/kdegraphics/files/digest-kdegraphics-2.2 b/kde-base/kdegraphics/files/digest-kdegraphics-2.2
new file mode 100644
index 000000000000..69cb98089921
--- /dev/null
+++ b/kde-base/kdegraphics/files/digest-kdegraphics-2.2
@@ -0,0 +1 @@
+MD5 32125d00243c884017daa4345b87e2fe kdegraphics-2.2.tar.bz2
diff --git a/kde-base/kdegraphics/kdegraphics-2.2.ebuild b/kde-base/kdegraphics/kdegraphics-2.2.ebuild
new file mode 100644
index 000000000000..617541736fbf
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-2.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+
+V=2.2
+A=${PN}-${V}.tar.bz2
+S=${WORKDIR}/${PN}-${V}
+DESCRIPTION="KDE ${V} - Graphics"
+SRC_PATH="kde/stable/${V}/src/${A}"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.fh-heilbronn.de/pub/mirrors/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+HOMEPAGE="http://www.kde.org"
+
+DEPEND=">=kde-base/kdelibs-${PV} sys-devel/perl
+ tex? ( >=app-text/tetex-1.0.7 )
+ gphoto2? ( >=gnome-apps/gphoto-2.0_beta1 >=media-libs/libgpio-20010607 )"
+
+RDEPEND=">=kde-base/kdelibs-${PV} gphoto2? ( >=gnome-apps/gphoto-2.0_beta1 >=media-libs/libgpio-20010607 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+# patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ QTBASE=/usr/X11R6/lib/qt
+ local myconf
+ if [ "`use qtmt`" ]
+ then
+ myconf="--enable-mt"
+ fi
+ if [ "`use mitshm`" ]
+ then
+ myconf="$myconf --enable-mitshm"
+ fi
+ if [ "`use gphoto2`" ] ; then
+ myconf="$myconf --with-gphoto2-includes=/usr/include/gphoto2 --with-gphoto2-libraries=/usr/lib/gphoto2"
+ else
+ myconf="$myconf --without-kamera"
+ fi
+ try ./configure --prefix=${KDEDIR} --host=${CHOST} \
+ --with-qt-dir=$QTBASE $myconf --with-xinerama
+ try make
+}
+
+src_install() {
+ try make install DESTDIR=${D}
+ dodoc AUTHORS COPYING README ChangeLog
+}
+
+
+
+