summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2003-04-08 17:57:41 +0000
committerDan Armak <danarmak@gentoo.org>2003-04-08 17:57:41 +0000
commit9b6a6c10fb029bd66191c780ed7d69b8b85e19d8 (patch)
treeffa48e1f42268a27ddb124ba557fdab11609652f /kde-base/kdelibs
parentneeded support for new kde 3.1.1a stuff. shouldn't touch anything else. (diff)
downloadhistorical-9b6a6c10fb029bd66191c780ed7d69b8b85e19d8.tar.gz
historical-9b6a6c10fb029bd66191c780ed7d69b8b85e19d8.tar.bz2
historical-9b6a6c10fb029bd66191c780ed7d69b8b85e19d8.zip
upcoming kde - see -core posts
Diffstat (limited to 'kde-base/kdelibs')
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.1.1a15
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.1.1a-kjs-alphaev6-gcc3-workaround.patch19
-rw-r--r--kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild4
-rw-r--r--kde-base/kdelibs/kdelibs-3.1.1a.ebuild79
4 files changed, 115 insertions, 2 deletions
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.1.1a b/kde-base/kdelibs/files/digest-kdelibs-3.1.1a
new file mode 100644
index 000000000000..0d1b0ca646e8
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.1.1a
@@ -0,0 +1,15 @@
+MD5 3c178889822836378fcf526195b86814 /files/kdelibs-3.1.1-kio_http.diff 5257
+MD5 24190dc0508cd29ea5adecc4cefc0db2 /files/kdelibs-2.2.2a-crosside.diff 1267
+MD5 b9e995da45022f78aed48a79f02201e7 /files/kdelibs-3.1-bookmark.diff 1320
+MD5 41d30ba8cf8d36ad3caebeedb1ddfd0e /files/kdelibs-3.1.1-kjs-alphaev6-gcc3-workaround.patch 477
+MD5 7353213c0eaadb42e684fb98fe8f4ff0 /files/kdelibs-3.1.1-zip.diff 2906
+MD5 7353213c0eaadb42e684fb98fe8f4ff0 /files/kdelibs-3.1-zip.diff 2906
+MD5 41d30ba8cf8d36ad3caebeedb1ddfd0e /files/kdelibs-3.1.1a-kjs-alphaev6-gcc3-workaround.patch 477
+MD5 41d30ba8cf8d36ad3caebeedb1ddfd0e /files/kdelibs-3.1-kjs-alphaev6-gcc3-workaround.patch 477
+MD5 bcd0e223c0be9cc4d1af5f2b5578a096 /files/kdelibs-3.0.5a-dontcrash.diff 500
+MD5 ed6c2a4ca2dca736f3cbfe717b762fe6 /files/kdelibs-2.2.2a-gentoo.diff 75788
+MD5 6e7c2097ad93ecd9a011d1685cb8971f /files/kdelibs-3.1-libxml2-2.5.2.diff 1404
+MD5 acd90863c0847e230aa37f3943d58176 /files/kdelibs-3.0.5a-libxml2-2.5.2.diff 703
+MD5 364c49d612f6357e04250003d94ac5d8 /kdelibs-3.1.1a.ebuild 2588
+MD5 5687b1f9d7e0698f63c35c53322c786a kdelibs-3.1.1a.diff.bz2 156512
+MD5 15eb9412c589126844b277b9e80cfffc kdelibs-3.1.1.tar.bz2 10313173
diff --git a/kde-base/kdelibs/files/kdelibs-3.1.1a-kjs-alphaev6-gcc3-workaround.patch b/kde-base/kdelibs/files/kdelibs-3.1.1a-kjs-alphaev6-gcc3-workaround.patch
new file mode 100644
index 000000000000..930776d23a51
--- /dev/null
+++ b/kde-base/kdelibs/files/kdelibs-3.1.1a-kjs-alphaev6-gcc3-workaround.patch
@@ -0,0 +1,19 @@
+--- kjs/ustring.cpp.orig 2003-01-23 15:49:49.000000000 -0500
++++ kjs/ustring.cpp 2003-01-27 19:49:00.000000000 -0500
+@@ -421,8 +421,15 @@
+ {
+ double d = toDouble();
+ bool b = true;
++ /* useless temporary variable to work around gcc optimization bug */
++ bool nan = false;
+
+- if (isNaN(d) || d != static_cast<unsigned long>(d)) {
++ if (isNaN(d)) {
++ d = 0;
++ nan = true;
++ }
++
++ if (nan || d != static_cast<unsigned long>(d)) {
+ b = false;
+ d = 0;
+ }
diff --git a/kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild b/kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild
index e40350bc1d7e..1763c1680a27 100644
--- a/kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild,v 1.4 2003/03/31 13:36:24 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1.1-r1.ebuild,v 1.5 2003/04/08 17:57:27 danarmak Exp $
inherit kde kde.org
#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
@@ -16,7 +16,7 @@ PATCHES="${FILESDIR}/${P}-zip.diff"
# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
# so we recreate the entire DEPEND from scratch.
DEPEND=""
-RDEPEND=""
+RDEPEND="doc? ( ~app-doc/kdelibs-apidocs-$PV )"
newdepend "dev-lang/perl
>=media-libs/audiofile-0.1.9
>=sys-apps/bzip2-1.0.1
diff --git a/kde-base/kdelibs/kdelibs-3.1.1a.ebuild b/kde-base/kdelibs/kdelibs-3.1.1a.ebuild
new file mode 100644
index 000000000000..a8cba528621f
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.1.1a.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1.1a.ebuild,v 1.1 2003/04/08 17:57:27 danarmak Exp $
+inherit kde kde.org eutils
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+IUSE="alsa cups ipv6 ssl"
+DESCRIPTION="KDE libraries needed by all kde programs"
+KEYWORDS="x86 ~ppc sparc ~alpha"
+HOMEPAGE="http//www.kde.org/"
+SLOT="3.1"
+LICENSE="GPL-2 LGPL-2"
+
+# for the 3.1.1a version - use incremental patches from 3.1.1
+S=${WORKDIR}/${PN}-3.1.1
+PATCHES1="$PATCHES1 ${WORKDIR}/${P}.diff"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
+# so we recreate the entire DEPEND from scratch.
+DEPEND=""
+RDEPEND="doc? ( ~app-doc/kdelibs-apidocs-$PV )"
+newdepend "dev-lang/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 >=media-sound/alsa-driver-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ app-text/ghostscript
+ media-libs/libart_lgpl
+ sys-devel/gettext
+ ~kde-base/arts-1.1.1" # this arts rev is part of the same fix
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python
+ >=sys-apps/portage-2.0.36" # for #7359
+
+myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
+use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+use x86 && myconf="$myconf --enable-fast-malloc=full"
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+ kde_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+ use alpha && cd ${S} && epatch ${FILESDIR}/${P}-kjs-alphaev6-gcc3-workaround.patch
+}
+
+src_install() {
+ kde_src_install
+ dohtml *.html
+
+ # kdelibs-apidocs is provided by kdelibs-apidocs ebuild, kdelibs ebuild
+ # shouldn't install anything into kdelibs-apidocs (bug #15102)
+ rm -r ${D}/$KDEDIR/share/doc/HTML/en/kdelibs-apidocs
+}
+
+pkg_postinst() {
+ einfo "If you have kde 3.0.x installed, please upgrade to kdeils-3.0.5a-r2 and kdebase-3.0.5a-r1.
+ If they don't have your arch's keywords, edit /etc/env.d/65kdelibs-3.0.*, remove the KDEDIRS=
+ line and env-update."
+}