summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-08-02 11:29:09 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-08-02 11:29:09 +0000
commite1b8df46ff4521e3e375dfa093ed57e58114f916 (patch)
treef3eae0ab5b5e97f58eac4326aa6d82211ed21ccb /kde-base/kdepim
parentDon't inherit from gtk-engines2.eclass (diff)
downloadhistorical-e1b8df46ff4521e3e375dfa093ed57e58114f916.tar.gz
historical-e1b8df46ff4521e3e375dfa093ed57e58114f916.tar.bz2
historical-e1b8df46ff4521e3e375dfa093ed57e58114f916.zip
Add patch to fix problem with attachments (kde bug 109003).
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'kde-base/kdepim')
-rw-r--r--kde-base/kdepim/ChangeLog8
-rw-r--r--kde-base/kdepim/files/digest-kdepim-3.4.2-r11
-rw-r--r--kde-base/kdepim/files/kdepim-3.4.2-partnode.patch20
-rw-r--r--kde-base/kdepim/kdepim-3.4.2-r1.ebuild38
4 files changed, 66 insertions, 1 deletions
diff --git a/kde-base/kdepim/ChangeLog b/kde-base/kdepim/ChangeLog
index 9c3997cfa729..e4cfb9a033a5 100644
--- a/kde-base/kdepim/ChangeLog
+++ b/kde-base/kdepim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/ChangeLog,v 1.163 2005/07/28 19:53:17 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/ChangeLog,v 1.164 2005/08/02 11:29:08 greg_g Exp $
+
+*kdepim-3.4.2-r1 (02 Aug 2005)
+
+ 02 Aug 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/kdepim-3.4.2-partnode.patch, +kdepim-3.4.2-r1.ebuild:
+ Add patch to fix problem with attachments (kde bug 109003).
28 Jul 2005; Guy Martin <gmsoft@gentoo.org> kdepim-3.4.1-r2.ebuild:
Stable on hppa.
diff --git a/kde-base/kdepim/files/digest-kdepim-3.4.2-r1 b/kde-base/kdepim/files/digest-kdepim-3.4.2-r1
new file mode 100644
index 000000000000..6ac9eb92b059
--- /dev/null
+++ b/kde-base/kdepim/files/digest-kdepim-3.4.2-r1
@@ -0,0 +1 @@
+MD5 e7bd012faa559bcf2a949b6a8ed5ff7f kdepim-3.4.2.tar.bz2 11368492
diff --git a/kde-base/kdepim/files/kdepim-3.4.2-partnode.patch b/kde-base/kdepim/files/kdepim-3.4.2-partnode.patch
new file mode 100644
index 000000000000..98e55197db06
--- /dev/null
+++ b/kde-base/kdepim/files/kdepim-3.4.2-partnode.patch
@@ -0,0 +1,20 @@
+diff -Nur kdepim-3.4.2.orig/kmail/partNode.cpp kdepim-3.4.2/kmail/partNode.cpp
+--- kdepim-3.4.2.orig/kmail/partNode.cpp 2005-05-23 14:11:54.000000000 +0200
++++ kdepim-3.4.2/kmail/partNode.cpp 2005-08-02 12:05:32.000000000 +0200
+@@ -36,6 +36,7 @@
+ #include "kmmimeparttree.h"
+ #include <mimelib/utility.h>
+ #include <qregexp.h>
++#include <kasciistricmp.h>
+
+ /*
+ ===========================================================================
+@@ -414,7 +415,7 @@
+ partNode* partNode::findNodeForDwPart( DwBodyPart* part )
+ {
+ partNode* found = 0;
+- if( dwPart()->partId() == part->partId() )
++ if( kasciistricmp( dwPart()->partId(), part->partId() ) == 0 )
+ return this;
+ if( mChild )
+ found = mChild->findNodeForDwPart( part );
diff --git a/kde-base/kdepim/kdepim-3.4.2-r1.ebuild b/kde-base/kdepim/kdepim-3.4.2-r1.ebuild
new file mode 100644
index 000000000000..060843da8731
--- /dev/null
+++ b/kde-base/kdepim/kdepim-3.4.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.4.2-r1.ebuild,v 1.1 2005/08/02 11:29:08 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE PIM (Personal Information Management) apps: korganizer, kmail, knode..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="crypt gnokii pda"
+
+DEPEND="~kde-base/kdebase-${PV}
+ >=dev-libs/cyrus-sasl-2
+ pda? ( app-pda/pilot-link dev-libs/libmal )
+ gnokii? ( app-mobilephone/gnokii )
+ crypt? ( >=app-crypt/gpgme-0.9.0-r1 )"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix compilation with gcc 3.2 (kde bug 106274). Applied for 3.4.3.
+ epatch "${FILESDIR}/kdepim-3.4.2-gcc32.patch"
+
+ # Fix problem with attachments (kde bug 109003). Applied for 3.4.3.
+ epatch "${FILESDIR}/kdepim-3.4.2-partnode.patch"
+
+ # Configure patch. Applied for 3.5.
+ epatch "${FILESDIR}/kdepim-3.4-configure.patch"
+
+ # For the configure patch.
+ make -f admin/Makefile.common
+}
+
+src_compile() {
+ local myconf="--with-sasl $(use_with gnokii)"
+
+ kde_src_compile
+}