summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-11-09 02:52:26 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-11-09 02:52:26 +0000
commit884448fe539d8d03e15d3b454fb0413fe9b6fbbc (patch)
tree1f45a51ef736830a005781f5a511fee20d294f84 /kde-base/kdesu/kdesu-4.1.3.ebuild
parentFixup 4.1.3 mask, so no more empty lines. (diff)
downloadhistorical-884448fe539d8d03e15d3b454fb0413fe9b6fbbc.tar.gz
historical-884448fe539d8d03e15d3b454fb0413fe9b6fbbc.tar.bz2
historical-884448fe539d8d03e15d3b454fb0413fe9b6fbbc.zip
Full auto: Version bump for KDE-4.1.3
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26-gentoo i686
Diffstat (limited to 'kde-base/kdesu/kdesu-4.1.3.ebuild')
-rw-r--r--kde-base/kdesu/kdesu-4.1.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/kde-base/kdesu/kdesu-4.1.3.ebuild b/kde-base/kdesu/kdesu-4.1.3.ebuild
new file mode 100644
index 000000000000..d52e5bd56446
--- /dev/null
+++ b/kde-base/kdesu/kdesu-4.1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesu/kdesu-4.1.3.ebuild,v 1.1 2008/11/09 01:00:58 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME=kdebase-runtime
+inherit kde4-meta
+
+# FIXME: Is default command ( su/sudo ) still configurable,
+# if not, USE-flag ?
+DESCRIPTION="KDE: gui for su(1)"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook"
+
+src_configure() {
+ # Upstream moved kdesu to libexec first, then decided to move it back
+ # to /${PREFIX}/bin/ , so I'm doing that now already.
+ sed -e '/kdesu_executable/s:LIBEXEC_INSTALL_DIR:BIN_INSTALL_DIR:' \
+ -i "${S}"/kdesu/kdesu/CMakeLists.txt || \
+ die "Moving kdesu from libexec to bin failed."
+
+ kde4-meta_src_configure
+}