summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-10-02 18:12:30 +0000
committerJohannes Huber <johu@gentoo.org>2012-10-02 18:12:30 +0000
commite24d1892c460e245f1dd758fe478f50e1365610d (patch)
treecdfa55b52059355077e16df18b81627a78ffa553 /kde-base/kimono
parentUpdate dev channel mask for beta release of chromium-23. (diff)
downloadhistorical-e24d1892c460e245f1dd758fe478f50e1365610d.tar.gz
historical-e24d1892c460e245f1dd758fe478f50e1365610d.tar.bz2
historical-e24d1892c460e245f1dd758fe478f50e1365610d.zip
Version bump KDE SC 4.9.2
Package-Manager: portage-2.2.0_alpha134/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kimono')
-rw-r--r--kde-base/kimono/ChangeLog7
-rw-r--r--kde-base/kimono/kimono-4.9.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/kimono/ChangeLog b/kde-base/kimono/ChangeLog
index 5c5afed15409..4b1dad506466 100644
--- a/kde-base/kimono/ChangeLog
+++ b/kde-base/kimono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kimono
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.42 2012/09/21 09:32:55 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.43 2012/10/02 18:11:50 johu Exp $
+
+*kimono-4.9.2 (02 Oct 2012)
+
+ 02 Oct 2012; Johannes Huber <johu@gentoo.org> +kimono-4.9.2.ebuild:
+ Version bump KDE SC 4.9.2
21 Sep 2012; Johannes Huber <johu@gentoo.org> -kimono-4.9.0.ebuild:
Remove KDE SC 4.9.0
diff --git a/kde-base/kimono/kimono-4.9.2.ebuild b/kde-base/kimono/kimono-4.9.2.ebuild
new file mode 100644
index 000000000000..0c4d7ff40647
--- /dev/null
+++ b/kde-base/kimono/kimono-4.9.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/kimono-4.9.2.ebuild,v 1.1 2012/10/02 18:11:50 johu Exp $
+
+EAPI=4
+
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for KDE"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug plasma semantic-desktop"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep qyoto 'webkit')
+ $(add_kdebase_dep smokeqt)
+ $(add_kdebase_dep smokekde 'semantic-desktop=')
+ plasma? ( $(add_kdebase_dep smokeqt 'webkit') )
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -i "/add_subdirectory( examples )/ s:^:#:" plasma/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ -DWITH_Soprano=OFF
+ )
+ kde4-base_src_configure
+}