summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-11-20 12:50:44 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-11-20 12:50:44 +0000
commit258a6bd22959817a7820a29aa649232c57b36113 (patch)
treedc2fb09cb851eed885f8384bb12458d69a61ae2c /kde-base/kmilo/kmilo-3.5.8-r1.ebuild
parentUnmask the USE=mtp use flag (libmtp verified to work by Willy Gardiol ). (diff)
downloadhistorical-258a6bd22959817a7820a29aa649232c57b36113.tar.gz
historical-258a6bd22959817a7820a29aa649232c57b36113.tar.bz2
historical-258a6bd22959817a7820a29aa649232c57b36113.zip
Added a patch to fix a problem with the XF86Audio* key handlers not working when there's no master channel (e. g. you have a mute key that stopped working in KDE). Fixes bug 198015. Thanks to Kelvie Wong for creating and submitting said patch.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'kde-base/kmilo/kmilo-3.5.8-r1.ebuild')
-rw-r--r--kde-base/kmilo/kmilo-3.5.8-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/kde-base/kmilo/kmilo-3.5.8-r1.ebuild b/kde-base/kmilo/kmilo-3.5.8-r1.ebuild
new file mode 100644
index 000000000000..ce01f97c0be3
--- /dev/null
+++ b/kde-base/kmilo/kmilo-3.5.8-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmilo/kmilo-3.5.8-r1.ebuild,v 1.1 2007/11/20 12:50:43 philantrop Exp $
+
+KMNAME=kdeutils
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="kmilo - a kded module that can be extended to support various types of hardware
+input devices that exist, such as those on keyboards."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility pbbuttonsd"
+DEPEND="pbbuttonsd? ( app-laptop/pbbuttonsd )"
+RDEPEND="${DEPEND}"
+
+PATCHES="${FILESDIR}/${P}-198015_XF86Audio.patch"
+
+src_compile() {
+ local myconf="$(use_with pbbuttonsd powerbook)"
+
+ kde-meta_src_compile
+}