summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
commit96b2ccccbdb3a629585880f16ae065b3a046ecf8 (patch)
tree8614154608c173341cea9bbafdd085551b050be8 /kde-base/kmix/kmix-4.9.1.ebuild
parentAdd net-misc/leechcraft-launchy, thanks to 0xd34df00d (diff)
downloadhistorical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.gz
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.bz2
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.zip
Version bump KDE SC 4.9.1
Package-Manager: portage-2.2.0_alpha124/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kmix/kmix-4.9.1.ebuild')
-rw-r--r--kde-base/kmix/kmix-4.9.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-base/kmix/kmix-4.9.1.ebuild b/kde-base/kmix/kmix-4.9.1.ebuild
new file mode 100644
index 000000000000..e028f4786fe8
--- /dev/null
+++ b/kde-base/kmix/kmix-4.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmix/kmix-4.9.1.ebuild,v 1.1 2012/09/04 18:44:57 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE mixer gui"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="alsa debug canberra pulseaudio"
+
+DEPEND="
+ alsa? ( >=media-libs/alsa-lib-1.0.14a )
+ canberra? ( media-libs/libcanberra )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.12 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with canberra)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-base_src_configure
+}