summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
commit881e446ad159543c84e6f5710f10814c66f875f3 (patch)
treefb5718e17dbc5a4f0b570ece0495be9a82fb2ced /kde-base/ksplash
parentversion bump for bug 424525, ebuild provided by Ortwin Glück (diff)
downloadhistorical-881e446ad159543c84e6f5710f10814c66f875f3.tar.gz
historical-881e446ad159543c84e6f5710f10814c66f875f3.tar.bz2
historical-881e446ad159543c84e6f5710f10814c66f875f3.zip
Version bump KDE SC 4.9.0
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.9.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 2fd42188b6fb..61cb3555ec9f 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.128 2012/06/21 21:54:50 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.129 2012/08/01 22:17:17 johu Exp $
+
+*ksplash-4.9.0 (01 Aug 2012)
+
+ 01 Aug 2012; Johannes Huber <johu@gentoo.org> +ksplash-4.9.0.ebuild:
+ Version bump KDE SC 4.9.0
*ksplash-4.8.4 (21 Jun 2012)
diff --git a/kde-base/ksplash/ksplash-4.9.0.ebuild b/kde-base/ksplash/ksplash-4.9.0.ebuild
new file mode 100644
index 000000000000..9e2503ef8fe3
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.9.0.ebuild,v 1.1 2012/08/01 22:17:17 johu Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama)
+ )
+
+ kde4-meta_src_configure
+}