summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2006-01-22 22:53:11 +0000
committerDan Armak <danarmak@gentoo.org>2006-01-22 22:53:11 +0000
commit098de7f13b6e71962ecfbe634bac40e00cdcca38 (patch)
tree26cd80709dc2e87a6b53e9a29286d8f6f2997243 /kde-base/ksplashml/ksplashml-3.5.1.ebuild
parentUpdate HOMEPAGE and use our mirrors for bug 119981. (diff)
downloadhistorical-098de7f13b6e71962ecfbe634bac40e00cdcca38.tar.gz
historical-098de7f13b6e71962ecfbe634bac40e00cdcca38.tar.bz2
historical-098de7f13b6e71962ecfbe634bac40e00cdcca38.zip
KDE 3.5.1 split ebuilds (still masked since not officially released upstream, devs can get the sources from my homedir on dev.gentoo.org as usual)
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'kde-base/ksplashml/ksplashml-3.5.1.ebuild')
-rw-r--r--kde-base/ksplashml/ksplashml-3.5.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/kde-base/ksplashml/ksplashml-3.5.1.ebuild b/kde-base/ksplashml/ksplashml-3.5.1.ebuild
new file mode 100644
index 000000000000..208727232a11
--- /dev/null
+++ b/kde-base/ksplashml/ksplashml-3.5.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplashml/ksplashml-3.5.1.ebuild,v 1.1 2006/01/22 22:53:06 danarmak Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xinerama"
+
+RDEPEND="xinerama? ( || ( x11-libs/libXinerama virtual/x11 ) )"
+
+DEPEND="${RDEPEND}
+ xinerama? ( || ( x11-proto/xineramaproto virtual/x11 ) )"
+
+src_compile() {
+ myconf="${myconf} $(use_with xinerama)"
+
+ kde-meta_src_compile
+}