summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
commitb900c5b419baaf47bcd309ef6d8a932d630c79be (patch)
tree0ac77639648e73041ce5b313801ae2608e40ce15 /kde-base/ksysguard/ksysguard-4.5.2.ebuild
parentFix libpng SLOT depend wrt #339796 by "MaratIK". (diff)
downloadhistorical-b900c5b419baaf47bcd309ef6d8a932d630c79be.tar.gz
historical-b900c5b419baaf47bcd309ef6d8a932d630c79be.tar.bz2
historical-b900c5b419baaf47bcd309ef6d8a932d630c79be.zip
Add KDE SC 4.5.2 =)
Package-Manager: portage-2.2_rc88_p115/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/ksysguard/ksysguard-4.5.2.ebuild')
-rw-r--r--kde-base/ksysguard/ksysguard-4.5.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-base/ksysguard/ksysguard-4.5.2.ebuild b/kde-base/ksysguard/ksysguard-4.5.2.ebuild
new file mode 100644
index 000000000000..e229751a5e1b
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.5.2.ebuild,v 1.1 2010/10/06 09:17:06 alexxy Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug lm_sensors"
+
+COMMONDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}"
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with lm_sensors Sensors)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ ewarn "Note that ksysguard has powerful features; one of these is the executing of arbitrary"
+ ewarn "programs with elevated privileges (as data sources). So be careful opening worksheets"
+ ewarn "from untrusted sources!"
+}