summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-10-02 18:12:30 +0000
committerJohannes Huber <johu@gentoo.org>2012-10-02 18:12:30 +0000
commite24d1892c460e245f1dd758fe478f50e1365610d (patch)
treecdfa55b52059355077e16df18b81627a78ffa553 /kde-base/phonon-kde
parentUpdate dev channel mask for beta release of chromium-23. (diff)
downloadhistorical-e24d1892c460e245f1dd758fe478f50e1365610d.tar.gz
historical-e24d1892c460e245f1dd758fe478f50e1365610d.tar.bz2
historical-e24d1892c460e245f1dd758fe478f50e1365610d.zip
Version bump KDE SC 4.9.2
Package-Manager: portage-2.2.0_alpha134/cvs/Linux x86_64
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog7
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.9.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index 515755b4c941..6ef4ae58d69b 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.135 2012/09/21 09:33:15 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.136 2012/10/02 18:11:53 johu Exp $
+
+*phonon-kde-4.9.2 (02 Oct 2012)
+
+ 02 Oct 2012; Johannes Huber <johu@gentoo.org> +phonon-kde-4.9.2.ebuild:
+ Version bump KDE SC 4.9.2
21 Sep 2012; Johannes Huber <johu@gentoo.org> -phonon-kde-4.9.0.ebuild:
Remove KDE SC 4.9.0
diff --git a/kde-base/phonon-kde/phonon-kde-4.9.2.ebuild b/kde-base/phonon-kde/phonon-kde-4.9.2.ebuild
new file mode 100644
index 000000000000..ebeed3b78a1e
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.9.2.ebuild,v 1.1 2012/10/02 18:11:53 johu Exp $
+
+EAPI=4
+
+KMNAME="kde-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="alsa debug pulseaudio"
+
+DEPEND="
+ >=media-libs/phonon-4.4.3
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libcanberra
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_tests=OFF
+ -DWITH_Xine=OFF
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-meta_src_configure
+}