summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
commit86166760b8aa7e1c789581787e2f7bd3d159df87 (patch)
tree3c1095c1c98ae9f6510c9d93134aa0062970a3bd /kde-base/quanta/quanta-3.5.9.ebuild
parentEnabled support for openmpi and mpich2 (see bug #210639). (diff)
downloadhistorical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.gz
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.bz2
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.zip
Version bump to KDE 3.5.9.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/quanta/quanta-3.5.9.ebuild')
-rw-r--r--kde-base/quanta/quanta-3.5.9.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/quanta/quanta-3.5.9.ebuild b/kde-base/quanta/quanta-3.5.9.ebuild
new file mode 100644
index 000000000000..10f284c920f3
--- /dev/null
+++ b/kde-base/quanta/quanta-3.5.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/quanta/quanta-3.5.9.ebuild,v 1.1 2008/02/20 23:35:25 philantrop Exp $
+KMNAME=kdewebdev
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE: Quanta Plus Web Development Environment"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc kdehiddenvisibility"
+
+DEPEND="dev-libs/libxslt
+ dev-libs/libxml2"
+RDEPEND="${RDEPEND}
+ doc? ( app-doc/quanta-docs )"
+
+KMCOMPILEONLY=lib
+
+# TODO: check why this wasn't needed back in the monolithic ebuild
+src_compile () {
+ myconf="--with-extra-includes=$(xml2-config --cflags | sed -e 's:^-I::')"
+ kde-meta_src_compile
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ echo
+ elog "${P} has some optional dependencies which you might want to emerge:"
+ elog "- app-text/htmltidy for HTML syntax checking."
+ elog "- app-crypt/gnupg for previewing browser configuration."
+ elog "- kde-base/kompare for comparing files by content."
+ elog "- kde-base/cervisia for enabling the CVS management plugin."
+ elog "- kde-base/kfilereplace for searching and replacing in files."
+ elog "- kde-base/kimagemapeditor for editing HTML image maps."
+ elog "- kde-base/klinkstatus for link validity checking."
+ elog "- kde-base/kxsldbg for XSLT debugging."
+ elog "- kde-base/kommander for the QuickStart dialogue and other scripted dialogues."
+ echo
+}