summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
commit5f9a89edfc761f6e642eaf86247fccacdd48d248 (patch)
treed6c5667c5d199a8f311d21b4e1273d740f0b4d06 /kde-base/qyoto
parent[profiles] Update kde mask (diff)
downloadhistorical-5f9a89edfc761f6e642eaf86247fccacdd48d248.tar.gz
historical-5f9a89edfc761f6e642eaf86247fccacdd48d248.tar.bz2
historical-5f9a89edfc761f6e642eaf86247fccacdd48d248.zip
[kde-base] Add KDE SC 4.7.1
Package-Manager: portage-2.2.0_alpha54/cvs/Linux x86_64
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.7.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index 9c12d4dd0ec4..2a86a69aed1e 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.1 2011/07/27 14:04:32 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.2 2011/09/07 20:13:43 alexxy Exp $
+
+*qyoto-4.7.1 (07 Sep 2011)
+
+ 07 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org> +qyoto-4.7.1.ebuild:
+ Version bump KDE SC 4.7.1
*qyoto-4.7.0 (27 Jul 2011)
diff --git a/kde-base/qyoto/qyoto-4.7.1.ebuild b/kde-base/qyoto/qyoto-4.7.1.ebuild
new file mode 100644
index 000000000000..d9d8c4d37681
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.7.1.ebuild,v 1.1 2011/09/07 20:13:43 alexxy Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}