summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-16 00:58:17 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-16 00:58:17 +0000
commit0a0b4b4ce775cc8702649f1e9b5cdd77cf4cfdcb (patch)
tree9f1f4af69f6207707e3982c2ea07d233631bdd57 /kde-base/superkaramba
parentAdded KDE 4.0.4 version of strigi-analyzer. Thanks to Jorge Manuel B. S. Vice... (diff)
downloadhistorical-0a0b4b4ce775cc8702649f1e9b5cdd77cf4cfdcb.tar.gz
historical-0a0b4b4ce775cc8702649f1e9b5cdd77cf4cfdcb.tar.bz2
historical-0a0b4b4ce775cc8702649f1e9b5cdd77cf4cfdcb.zip
Added KDE 4.0.4 version of superkaramba. Thanks to Jorge Manuel B. S. Vicetto.
Package-Manager: portage-2.1.5
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog9
-rw-r--r--kde-base/superkaramba/superkaramba-4.0.4.ebuild28
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index c429a0c32f55..a2c4d5d45d29 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.75 2008/05/14 12:01:54 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.76 2008/05/16 00:58:17 ingmar Exp $
+
+*superkaramba-4.0.4 (15 May 2008)
+
+ 15 May 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +superkaramba-4.0.4.ebuild:
+ Added KDE 4.0.4 version of superkaramba. Thanks to Jorge Manuel B. S.
+ Vicetto.
14 May 2008; Markus Rothe <corsair@gentoo.org> superkaramba-3.5.9.ebuild:
Stable on ppc64; bug #221063
diff --git a/kde-base/superkaramba/superkaramba-4.0.4.ebuild b/kde-base/superkaramba/superkaramba-4.0.4.ebuild
new file mode 100644
index 000000000000..d26e22ca68a3
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.0.4.ebuild,v 1.1 2008/05/16 00:58:17 ingmar Exp $
+
+EAPI="1"
+
+KMNAME=kdeutils
+inherit kde4-meta
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook python"
+
+COMMONDEPEND="
+ kde-base/qimageblitz
+ >=kde-base/plasma-$PV:$SLOT
+ python? ( dev-lang/python )"
+DEPEND="${COMMONDEPEND}"
+RDEPEND="${COMMONDEPEND}"
+
+PATCHES="${FILESDIR}/${PN}-as-needed.patch"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with python PythonLibs)"
+
+ kde4-meta_src_compile
+}