summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-05-24 22:55:07 +0000
committerBen de Groot <yngwin@gentoo.org>2009-05-24 22:55:07 +0000
commit7d8e77cfa9ed24d7f2b3ae8e8a76001449ee899f (patch)
treeef762da05983f35b4af7b8a7b4acb9f66b3521b0 /lxde-base/lxpanel/lxpanel-0.4.1.ebuild
parentVersion bump (diff)
downloadhistorical-7d8e77cfa9ed24d7f2b3ae8e8a76001449ee899f.tar.gz
historical-7d8e77cfa9ed24d7f2b3ae8e8a76001449ee899f.tar.bz2
historical-7d8e77cfa9ed24d7f2b3ae8e8a76001449ee899f.zip
Version bump. Dropped ~ppc keyword because of unkeyworded deps.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'lxde-base/lxpanel/lxpanel-0.4.1.ebuild')
-rw-r--r--lxde-base/lxpanel/lxpanel-0.4.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/lxde-base/lxpanel/lxpanel-0.4.1.ebuild b/lxde-base/lxpanel/lxpanel-0.4.1.ebuild
new file mode 100644
index 000000000000..52c9d172614c
--- /dev/null
+++ b/lxde-base/lxpanel/lxpanel-0.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.4.1.ebuild,v 1.1 2009/05/24 22:55:07 yngwin Exp $
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="+X +alsa wifi"
+RESTRICT="test" # bug 249598
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXmu
+ x11-libs/libXpm
+ lxde-base/lxmenu-data
+ lxde-base/menu-cache
+ alsa? ( media-libs/alsa-lib )
+ wifi? ( net-wireless/wireless-tools )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ econf $(use_enable alsa) \
+ $(use_enable wifi libiw) \
+ $(use_with X x) \
+ --with-plugins=all
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+}