summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2007-06-23 18:10:08 +0000
committerMarius Mauch <genone@gentoo.org>2007-06-23 18:10:08 +0000
commit00160fc837ddabb16eedfe8d2c403ef29b44440d (patch)
tree87efaf604375e2ddf0d92f828bf61cd7c7652739 /mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild
parentold (diff)
downloadhistorical-00160fc837ddabb16eedfe8d2c403ef29b44440d.tar.gz
historical-00160fc837ddabb16eedfe8d2c403ef29b44440d.tar.bz2
historical-00160fc837ddabb16eedfe8d2c403ef29b44440d.zip
Check that pinentry was merged with USE=gtk or USE=qt3 (bug #170967)
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild')
-rw-r--r--mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild b/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild
index d15aaf53f535..591a51aec8b4 100644
--- a/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild
+++ b/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild,v 1.1 2007/06/23 14:15:52 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild,v 1.2 2007/06/23 18:05:54 genone Exp $
IUSE="gnome dillo crypt spell ssl ldap ipv6 pda clamav xface kde imap spamassassin doc startup-notification bogofilter"
@@ -47,6 +47,18 @@ RDEPEND="${COMMONDEPEND}
PLUGIN_NAMES="acpi-notifier att-remover cachesaver etpan-privacy fetchinfo gtkhtml maildir mailmbox newmail notification pdf-viewer perl rssyl smime synce vcalendar"
+pkg_setup() {
+ # we have to make sure that pinentry has gtk support for GPG support
+ if use crypt && ! built_with_use --missing true -o app-crypt/pinentry gtk qt3; then
+ eerror "You need to merge app-crypt/pinentry with USE=gtk or USE=qt3"
+ eerror "for working GPG support. You have the following options:"
+ eerror " - remerge app-crypt/pinentry with USE=gtk"
+ eerror " - remerge app-crypt/pinentry with USE=qt3"
+ eerror " - disable GPG support by setting USE=-crypt for this package"
+ die "missing gtk/qt support in app-crypt/pinentry"
+ fi
+}
+
src_compile() {
local myconf