summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-07-20 20:09:35 +0000
committerFabian Groffen <grobian@gentoo.org>2009-07-20 20:09:35 +0000
commit6947877f170f1d8995e45b45367299454dfa8d2a (patch)
tree33b464f84f5af769562dae700957cf25df1a5ed5 /mail-client/mutt/files
parentAutomated update of use.local.desc (diff)
downloadhistorical-6947877f170f1d8995e45b45367299454dfa8d2a.tar.gz
historical-6947877f170f1d8995e45b45367299454dfa8d2a.tar.bz2
historical-6947877f170f1d8995e45b45367299454dfa8d2a.zip
Apply follow-up patch for tab-subject-questionmark patch, add new patch for new mail in mailboxes just left, rename gpgme USE-flag to gpg, require <gpgme-1.2.0 for now, since 1.2.0 doesn't really work, bug #278394
Package-Manager: portage-2.2.00.13830-prefix/cvs/Darwin powerpc
Diffstat (limited to 'mail-client/mutt/files')
-rw-r--r--mail-client/mutt/files/mutt-1.5.20-leave-mailbox-no-new-mail-118b8fef8aae.patch86
-rw-r--r--mail-client/mutt/files/mutt-1.5.20-tab-subject-questionmark-298194c414f0-cff8e8ce4327.patch38
2 files changed, 124 insertions, 0 deletions
diff --git a/mail-client/mutt/files/mutt-1.5.20-leave-mailbox-no-new-mail-118b8fef8aae.patch b/mail-client/mutt/files/mutt-1.5.20-leave-mailbox-no-new-mail-118b8fef8aae.patch
new file mode 100644
index 000000000000..b9088e727766
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.20-leave-mailbox-no-new-mail-118b8fef8aae.patch
@@ -0,0 +1,86 @@
+http://dev.mutt.org/trac/changeset/118b8fef8aae
+http://dev.mutt.org/trac/ticket/3290
+
+Suppress new mail notification from mailbox just left. Closes #3290.
+
+
+Index: buffy.c
+===================================================================
+--- buffy.c (revision 5914:25e46aad362b)
++++ buffy.c (revision 5973:118b8fef8aae)
+@@ -45,4 +45,6 @@
+ static short BuffyCount = 0; /* how many boxes with new mail */
+ static short BuffyNotify = 0; /* # of unnotified new boxes */
++
++static BUFFY* buffy_get (const char *path);
+
+ /* Find the last message in the file.
+@@ -498,4 +500,15 @@
+ }
+
++void mutt_buffy_setnotified (const char *path)
++{
++ BUFFY *buffy;
++
++ buffy = buffy_get(path);
++ if (!buffy)
++ return;
++
++ buffy->notified = 1;
++}
++
+ int mutt_buffy_notify (void)
+ {
+@@ -542,2 +555,29 @@
+ *s = '\0';
+ }
++
++/* fetch buffy object for given path, if present */
++static BUFFY* buffy_get (const char *path)
++{
++ BUFFY *cur;
++ char *epath;
++
++ if (!path)
++ return NULL;
++
++ epath = safe_strdup(path);
++ mutt_expand_path(epath, mutt_strlen(epath));
++
++ for (cur = Incoming; cur; cur = cur->next)
++ {
++ /* must be done late because e.g. IMAP delimiter may change */
++ mutt_expand_path (cur->path, sizeof (cur->path));
++ if (!mutt_strcmp(cur->path, path))
++ {
++ FREE (&epath);
++ return cur;
++ }
++ }
++
++ FREE (&epath);
++ return NULL;
++}
+Index: buffy.h
+===================================================================
+--- buffy.h (revision 5779:7bc332ddd8fc)
++++ buffy.h (revision 5973:118b8fef8aae)
+@@ -44,2 +44,5 @@
+ according to stat() info taken before a modification */
+ void mutt_buffy_cleanup (const char *buf, struct stat *st);
++
++/* mark mailbox just left as already notified */
++void mutt_buffy_setnotified (const char *path);
+Index: mx.c
+===================================================================
+--- mx.c (revision 5930:ed7eb5de7536)
++++ mx.c (revision 5973:118b8fef8aae)
+@@ -706,4 +706,8 @@
+ return;
+
++ /* never announce that a mailbox we've just left has new mail. #3290
++ * XXX: really belongs in mx_close_mailbox, but this is a nice hook point */
++ mutt_buffy_setnotified(ctx->path);
++
+ if (ctx->mx_close)
+ ctx->mx_close (ctx);
diff --git a/mail-client/mutt/files/mutt-1.5.20-tab-subject-questionmark-298194c414f0-cff8e8ce4327.patch b/mail-client/mutt/files/mutt-1.5.20-tab-subject-questionmark-298194c414f0-cff8e8ce4327.patch
new file mode 100644
index 000000000000..9aa969d0696e
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.20-tab-subject-questionmark-298194c414f0-cff8e8ce4327.patch
@@ -0,0 +1,38 @@
+http://dev.mutt.org/trac/changeset/298194c414f0
+
+Allow tabs in index subject. Closes #3270.
+
+http://dev.mutt.org/trac/changeset/cff8e8ce4327
+
+Render blanks to spaces in index, fixes [298194c414f0]
+
+wcwidth(<tab>) returns -1 so 'foo<tab>bar' was rendered to 'foobar',
+and now to 'foo bar'. Closes #3270 again.
+
+
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 5939:199b126a7623)
++++ configure.ac (revision 5958:298194c414f0)
+@@ -1216,5 +1216,5 @@
+
+ AC_CHECK_HEADERS(wctype.h)
+-AC_CHECK_FUNCS(iswalnum iswalpha iswcntrl iswdigit)
++AC_CHECK_FUNCS(iswalnum iswalpha iswblank iswcntrl iswdigit)
+ AC_CHECK_FUNCS(iswgraph iswlower iswprint iswpunct iswspace iswupper)
+ AC_CHECK_FUNCS(iswxdigit towupper towlower)
+Index: curs_lib.c
+===================================================================
+--- curs_lib.c (revision 5936:642987450d83)
++++ curs_lib.c (revision 5958:cff8e8ce4327)
+@@ -726,5 +726,10 @@
+ else
+ {
++#ifdef HAVE_ISWBLANK
++ if (iswblank (wc))
++ wc = ' ';
++ else
++#endif
+ if (!IsWPrint (wc))
+ wc = '?';
+ w = wcwidth (wc);