summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2013-07-23 17:32:43 +0000
committerFabian Groffen <grobian@gentoo.org>2013-07-23 17:32:43 +0000
commit08c481bb8dbd8eabbc761f9b68ec27e580fbf795 (patch)
tree124bc356037e7a89c04bb4db0f8428b5c1a33b68 /mail-mta/exim/exim-4.80.1.ebuild
parentCorrect tmpfiles.setup init script name in depend() (diff)
downloadhistorical-08c481bb8dbd8eabbc761f9b68ec27e580fbf795.tar.gz
historical-08c481bb8dbd8eabbc761f9b68ec27e580fbf795.tar.bz2
historical-08c481bb8dbd8eabbc761f9b68ec27e580fbf795.zip
Fix/improve locating MySQL and PostgreSQL libraries, patch by Alexander Tsoy in bug #477792
Package-Manager: portage-2.2.01.22124-prefix/cvs/Darwin i386 Manifest-Sign-Key: 0x5F75F607C5C74E89
Diffstat (limited to 'mail-mta/exim/exim-4.80.1.ebuild')
-rw-r--r--mail-mta/exim/exim-4.80.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/mail-mta/exim/exim-4.80.1.ebuild b/mail-mta/exim/exim-4.80.1.ebuild
index 1e261a4b07dc..96a2d7c3fd15 100644
--- a/mail-mta/exim/exim-4.80.1.ebuild
+++ b/mail-mta/exim/exim-4.80.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.80.1.ebuild,v 1.13 2013/03/23 18:00:38 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/exim/exim-4.80.1.ebuild,v 1.14 2013/07/23 17:32:39 grobian Exp $
EAPI="3"
@@ -232,14 +232,14 @@ src_configure() {
if use mysql; then
sed -i "s:# LOOKUP_MYSQL=yes:LOOKUP_MYSQL=yes:" Makefile
- LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I${EROOT}usr/include/mysql"
- LOOKUP_LIBS="$LOOKUP_LIBS -lmysqlclient"
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE $(mysql_config --include)"
+ LOOKUP_LIBS="$LOOKUP_LIBS $(mysql_config --libs)"
fi
if use postgres; then
sed -i "s:# LOOKUP_PGSQL=yes:LOOKUP_PGSQL=yes:" Makefile
- LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I${EROOT}usr/include/postgresql"
- LOOKUP_LIBS="$LOOKUP_LIBS -lpq"
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I$(pg_config --includedir)"
+ LOOKUP_LIBS="$LOOKUP_LIBS -L$(pg_config --libdir) -lpq"
fi
if use sqlite; then