summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-09-07 08:27:54 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-09-07 08:27:54 +0000
commit480342fdd348831abb66b006c4144a077f55cc36 (patch)
treea4532c6aea7d60406c4a80673c2979d73cae31c9 /mail-mta/msmtp/msmtp-1.2.3.ebuild
parentStable on x86, alpha and ppc. (diff)
downloadhistorical-480342fdd348831abb66b006c4144a077f55cc36.tar.gz
historical-480342fdd348831abb66b006c4144a077f55cc36.tar.bz2
historical-480342fdd348831abb66b006c4144a077f55cc36.zip
Version bump to 1.2.3. Fixes bug #62968. Added dev-util/pkgconfig to DEPEND.
Diffstat (limited to 'mail-mta/msmtp/msmtp-1.2.3.ebuild')
-rw-r--r--mail-mta/msmtp/msmtp-1.2.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/mail-mta/msmtp/msmtp-1.2.3.ebuild b/mail-mta/msmtp/msmtp-1.2.3.ebuild
new file mode 100644
index 000000000000..95959f71ae58
--- /dev/null
+++ b/mail-mta/msmtp/msmtp-1.2.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/msmtp-1.2.3.ebuild,v 1.1 2004/09/07 08:27:54 ticho Exp $
+
+DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
+HOMEPAGE="http://msmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+IUSE="ssl gnutls sasl"
+DEPEND="virtual/libc
+ dev-util/pkgconfig
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-1.0.0 )
+ !gnutls? ( >=dev-libs/openssl-0.9.6 )
+ )
+ sasl? ( virtual/gsasl )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+src_compile () {
+ local myconf
+
+ use sasl \
+ && myconf="${myconf} --enable-gsasl" \
+ || myconf="${myconf} --disable-gsasl"
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --enable-ssl --with-ssl=gnutls"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --enable-ssl --with-ssl=openssl"
+ else
+ myconf="${myconf} --disable-ssl"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install () {
+ einstall || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS \
+ doc/msmtprc.example doc/Mutt+msmtp.txt || die "dodoc failed"
+}