summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2009-09-05 14:31:03 +0000
committerMarkus Meier <maekke@gentoo.org>2009-09-05 14:31:03 +0000
commit59fcfb590151543dfbfce7216b74913051ccfc9d (patch)
tree34a8666ff9933b001e36c08f1afc69185b6cd260 /media-gfx/album/album-4.06.ebuild
parentarm/ia64/s390/sh/sparc stable wrt #282855 (diff)
downloadhistorical-59fcfb590151543dfbfce7216b74913051ccfc9d.tar.gz
historical-59fcfb590151543dfbfce7216b74913051ccfc9d.tar.bz2
historical-59fcfb590151543dfbfce7216b74913051ccfc9d.zip
version bump by Andreas K. Huettel in bug #276838
Package-Manager: portage-2.2_rc40/cvs/Linux i686
Diffstat (limited to 'media-gfx/album/album-4.06.ebuild')
-rw-r--r--media-gfx/album/album-4.06.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/album/album-4.06.ebuild b/media-gfx/album/album-4.06.ebuild
new file mode 100644
index 000000000000..e7a919511406
--- /dev/null
+++ b/media-gfx/album/album-4.06.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/album/album-4.06.ebuild,v 1.1 2009/09/05 14:31:03 maekke Exp $
+
+DATA_URI="http://marginalhacks.com/bin/album.versions/data-4.05.tar.gz"
+DESCRIPTION="HTML photo album generator"
+HOMEPAGE="http://MarginalHacks.com/Hacks/album/"
+SRC_URI="http://marginalhacks.com/bin/album.versions/${P}.tar.gz
+ themes? ( ${DATA_URI} )
+ plugins? ( ${DATA_URI} )"
+
+LICENSE="marginalhacks"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc ffmpeg plugins themes"
+
+DEPEND="virtual/libc"
+RDEPEND="dev-lang/perl
+ media-gfx/imagemagick
+ media-gfx/jhead
+ ffmpeg? ( media-video/ffmpeg )"
+
+src_install() {
+ dobin album
+ doman album.1
+ dodoc License.txt
+ use doc && dohtml -r Docs/*
+
+ dodir /usr/share/album
+ insinto /usr/share/album
+ cd ..
+ doins -r lang
+ use themes && doins -r Themes
+ use plugins && doins -r plugins
+}
+
+pkg_postinst() {
+ elog "For some optional tools please browse:"
+ elog "http://MarginalHacks.com/Hacks/album/tools/"
+}