summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-04-07 13:52:46 +0000
committerTroy Dack <tad@gentoo.org>2003-04-07 13:52:46 +0000
commit147fc8c9b01ea761dd71b92191ca93fc2801081b (patch)
tree38b218c727b021dd8d8ce73d471946a9b5117187 /media-gfx/bootsplash
parentUpdated named.ca (diff)
downloadhistorical-147fc8c9b01ea761dd71b92191ca93fc2801081b.tar.gz
historical-147fc8c9b01ea761dd71b92191ca93fc2801081b.tar.bz2
historical-147fc8c9b01ea761dd71b92191ca93fc2801081b.zip
New version & kernel patch - now with "silent" boot screen.
Diffstat (limited to 'media-gfx/bootsplash')
-rw-r--r--media-gfx/bootsplash/ChangeLog8
-rw-r--r--media-gfx/bootsplash/bootsplash-0.5.ebuild133
-rw-r--r--media-gfx/bootsplash/files/digest-bootsplash-0.42
-rw-r--r--media-gfx/bootsplash/files/digest-bootsplash-0.53
4 files changed, 145 insertions, 1 deletions
diff --git a/media-gfx/bootsplash/ChangeLog b/media-gfx/bootsplash/ChangeLog
index f5ad891e19dc..aea7c7f07fb4 100644
--- a/media-gfx/bootsplash/ChangeLog
+++ b/media-gfx/bootsplash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/bootsplash
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.5 2003/03/19 13:43:56 tad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.6 2003/04/07 13:50:50 tad Exp $
+
+*bootsplash-0.5 (07 Apr 2003)
+
+ 07 Apr 2003; Troy Dack <tad@gentoo.org> bootsplash-0.5.ebuild:
+ New kernel patch, new splash images. Now with a "silent" image and
+ a graphical progress bar.
*bootsplash-0.4-r1 (20 Mar 2003)
diff --git a/media-gfx/bootsplash/bootsplash-0.5.ebuild b/media-gfx/bootsplash/bootsplash-0.5.ebuild
new file mode 100644
index 000000000000..ecece3912e53
--- /dev/null
+++ b/media-gfx/bootsplash/bootsplash-0.5.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/bootsplash-0.5.ebuild,v 1.1 2003/04/07 13:50:51 tad Exp $
+
+DESCRIPTION="Graphical backgrounds for frame buffer consoles"
+
+HOMEPAGE="http://linux.tkdack.com"
+
+SRC_URI="http://gentoo.tkdack.com/downloads/gentoo/bootsplash-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=">=media-libs/freetype-2"
+
+# Not implemented yet
+# media-libs/libmng"
+
+RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ # compile utils
+
+# mng is not implmented yet
+# (the util builds but the rc scripts have not been modified)
+# cd ${S}/utils/fbmngplay
+# emake fbmngplay || die
+
+ cd ${S}/utils/fbtruetype
+ emake || die
+
+ cd ${S}/utils/splashutils
+ emake || die
+
+}
+
+src_install() {
+
+ # Splash utilities
+ exeinto /sbin
+# doexe ${S}/utils/fbmngplay/fbmngplay
+ doexe ${S}/utils/fbtruetype/fbtruetype
+ doexe ${S}/utils/fbtruetype/fbtruetype.static
+ doexe ${S}/utils/splashutils/splash
+ doexe ${S}/utils/splashutils/fbresolution
+ doexe ${S}/utils/splashutils/getkey
+
+ mkdir -p ${D}/etc/${PN}
+ cp -pR ${S}/themes/* ${D}/etc/${PN}
+
+ # link default config - for boot images
+ dosym ./gentoo /etc/bootsplash/default
+
+ insinto /etc/init.d
+ doins ${S}/misc/bootsplash
+ fperms 755 /etc/init.d/bootsplash
+
+ insinto /etc/conf.d
+ doins ${S}/misc/bootsplash.conf
+
+ insinto /usr/share/${PN}
+ doins ${S}/kernel/bootsplash-3.0.7-2.4.20-vanilla.diff
+ doins ${S}/misc/grub.conf.sample
+
+ for SIZE in 800x600 1024x768 1280x1024
+ do
+ ${D}/sbin/splash -s -f ${D}/etc/bootsplash/gentoo/config/bootsplash-${SIZE}.cfg > ${D}/usr/share/${PN}/initrd-${SIZE}
+ done
+
+# dodoc README
+# dodoc COPYING
+# dodoc CREDITS
+
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/media-gfx/${PN}/${P}.ebuild config\""
+ einfo "to have your kernel sources in /usr/src/linux patched with the"
+ einfo "Framebuffer Bootsplash patches"
+ einfo
+ echo ""
+ ewarn "If you have already patched the kernel then you only need to copy"
+ ewarn "an initrd from /usr/share/${PN} to /boot"
+ ewarn
+ echo ""
+ einfo
+ einfo "Run:"
+ einfo " rc-update add bootsplash default"
+ einfo " to change the console images after startup"
+ einfo
+}
+
+pkg_config() {
+ ewarn
+ ewarn "Patching the kernel in /usr/src/linux ..."
+ ewarn
+ cd ${ROOT}/usr/src/linux
+ patch -p1 < ${ROOT}/usr/share/${PN}/bootsplash-3.0.7-2.4.20-vanilla.diff || die
+ ewarn
+ ewarn " ... complete."
+ einfo
+ einfo "Your kernel has been patched, rebuild with the following options"
+ einfo "enabled (do not build them as modules!):"
+ einfo " Block Devices ->"
+ einfo " [*] RAM disk support"
+ einfo " [*] Loopback device support"
+ einfo " [*] Initial RAM disk (initrd) support"
+ einfo
+ einfo " Console Drivers ->"
+ einfo " [*] Video mode selection support"
+ einfo " Frame-buffer support ->"
+ einfo " [*] Support for frame buffer devices"
+ einfo " [*] VESA VGA graphics console"
+ einfo " [*] Use splash screen instead of boot logo"
+ einfo
+ einfo "Copy /usr/share/${PN}/initrd to /boot"
+ einfo
+ einfo "Look at \"/usr/share/${PN}/grub.conf.sample\" for an example"
+ einfo "grub.conf file with the appropriate changes to enable the"
+ einfo "framebuffer boot screens"
+ einfo
+ einfo "Ensure you make the appropriate changes to your grub.conf"
+ einfo
+}
diff --git a/media-gfx/bootsplash/files/digest-bootsplash-0.4 b/media-gfx/bootsplash/files/digest-bootsplash-0.4
index ff47ab2133d1..d366be6980b4 100644
--- a/media-gfx/bootsplash/files/digest-bootsplash-0.4
+++ b/media-gfx/bootsplash/files/digest-bootsplash-0.4
@@ -1 +1,3 @@
+MD5 ebc7af09da6a87c13759ed96eab28ca3 /files/bootsplash 946
+MD5 ecdf539ae9413be64382abc8979fc992 /bootsplash-0.4.ebuild 3014
MD5 2c074a46e2d229863b0df7c5dd9b21a3 bootsplash-0.4.tar.bz2 374032
diff --git a/media-gfx/bootsplash/files/digest-bootsplash-0.5 b/media-gfx/bootsplash/files/digest-bootsplash-0.5
new file mode 100644
index 000000000000..7cdfb85fb76e
--- /dev/null
+++ b/media-gfx/bootsplash/files/digest-bootsplash-0.5
@@ -0,0 +1,3 @@
+MD5 ebc7af09da6a87c13759ed96eab28ca3 /files/bootsplash 946
+MD5 e55381b7d9e8c6c901731bd41ec45f0d /bootsplash-0.5.ebuild 3339
+MD5 acfe7e5ed388af0e6a463d4530db3353 bootsplash-0.5.tar.bz2 235689