summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2007-03-05 23:34:41 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2007-03-05 23:34:41 +0000
commit5cb8145125d7048987cdd7e00096fa8fd4031157 (patch)
tree23a33deb39882ef792a93751c78e50d0710a1763 /media-gfx/exiv2/exiv2-0.13.ebuild
parentrm old version (diff)
downloadhistorical-5cb8145125d7048987cdd7e00096fa8fd4031157.tar.gz
historical-5cb8145125d7048987cdd7e00096fa8fd4031157.tar.bz2
historical-5cb8145125d7048987cdd7e00096fa8fd4031157.zip
version bump. new version features nls support and iconv is now a mandantory runtime dependency.
Package-Manager: portage-2.1.2-r2
Diffstat (limited to 'media-gfx/exiv2/exiv2-0.13.ebuild')
-rw-r--r--media-gfx/exiv2/exiv2-0.13.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-gfx/exiv2/exiv2-0.13.ebuild b/media-gfx/exiv2/exiv2-0.13.ebuild
new file mode 100644
index 000000000000..68f8ed2e7938
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.13.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.13.ebuild,v 1.1 2007/03/05 23:34:41 sbriesen Exp $
+
+inherit eutils
+
+DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
+HOMEPAGE="http://www.exiv2.org/"
+SRC_URI="http://www.exiv2.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+IUSE="doc nls zlib unicode"
+IUSE_LINGUAS="de es fi fr pl ru"
+
+for X in ${IUSE_LINGUAS}; do IUSE="${IUSE} linguas_${X}"; done
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ nls? ( virtual/libintl )
+ virtual/libiconv"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use unicode; then
+ einfo "Converting docs to UTF-8"
+ for i in doc/cmd.txt; do
+ iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable nls)"
+ use zlib || myconf="${myconf} --without-zlib" # plain 'use_with' fails
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README doc/{ChangeLog,cmd.txt}
+ use doc && dohtml doc/html/*
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "PLEASE PLEASE take note of this:"
+ ewarn "Please make *sure* to run revdep-rebuild now"
+ ewarn "Certain things on your system may have linked against a"
+ ewarn "different version of exiv2 -- those things need to be"
+ ewarn "recompiled. Sorry for the inconvenience!"
+ ewarn
+}