summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-12-10 04:18:56 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-12-10 04:18:56 +0000
commit581868a0b4f33a2e087f7a7f6131920bf44d1312 (patch)
tree62b04d2df744bb53c742cd74338dc7efe77566e0 /media-gfx/fotowall/fotowall-0.9-r1.ebuild
parent*portage-2.2_rc57 (10 Dec 2009) (diff)
downloadhistorical-581868a0b4f33a2e087f7a7f6131920bf44d1312.tar.gz
historical-581868a0b4f33a2e087f7a7f6131920bf44d1312.tar.bz2
historical-581868a0b4f33a2e087f7a7f6131920bf44d1312.zip
Revbump to fix webcam support. Remove old broken ebuild
Package-Manager: portage-2.2_rc56/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/fotowall/fotowall-0.9-r1.ebuild')
-rw-r--r--media-gfx/fotowall/fotowall-0.9-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-gfx/fotowall/fotowall-0.9-r1.ebuild b/media-gfx/fotowall/fotowall-0.9-r1.ebuild
new file mode 100644
index 000000000000..755440df1b95
--- /dev/null
+++ b/media-gfx/fotowall/fotowall-0.9-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fotowall/fotowall-0.9-r1.ebuild,v 1.1 2009/12/10 04:18:56 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4
+
+MY_P="${P/f/F}"
+
+DESCRIPTION="Qt4 tool for creating wallpapers"
+HOMEPAGE="http://www.enricoros.com/opensource/fotowall/"
+SRC_URI="http://fotowall.googlecode.com/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl webcam"
+
+DEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
+ opengl? ( x11-libs/qt-opengl:4 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ qt4_src_prepare
+
+ if ! use opengl; then
+ sed -i "/QT += opengl/d" "${PN}.pro" || die "sed failed"
+ fi
+}
+
+src_configure() {
+ if ! use webcam; then
+ eqmake4 ${PN}.pro "CONFIG += no-webcam"
+ else
+ eqmake4
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc "README.markdown" || die
+}