summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-21 16:56:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-21 16:56:27 +0000
commit9019e3e760b6b68be3eafd588d86f5c5c193d6da (patch)
treeb607c978c064ee04d2d39f69897b8b52b1455ecb /media-gfx/inkscape/files
parentQuote unquoted variable (diff)
downloadhistorical-9019e3e760b6b68be3eafd588d86f5c5c193d6da.tar.gz
historical-9019e3e760b6b68be3eafd588d86f5c5c193d6da.tar.bz2
historical-9019e3e760b6b68be3eafd588d86f5c5c193d6da.zip
old
Package-Manager: portage-2.2.0_alpha69/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/inkscape/files')
-rw-r--r--media-gfx/inkscape/files/inkscape-0.47-gcc45.patch83
-rw-r--r--media-gfx/inkscape/files/inkscape-0.47-poppler.patch110
-rw-r--r--media-gfx/inkscape/files/inkscape-0.48.0-libwpd.patch45
-rw-r--r--media-gfx/inkscape/files/inkscape-0.48.0-poppler-0.16.patch93
4 files changed, 0 insertions, 331 deletions
diff --git a/media-gfx/inkscape/files/inkscape-0.47-gcc45.patch b/media-gfx/inkscape/files/inkscape-0.47-gcc45.patch
deleted file mode 100644
index 643b7ff1d57b..000000000000
--- a/media-gfx/inkscape/files/inkscape-0.47-gcc45.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=305749
-
-diff -Naur inkscape-0.47-orig/src/eraser-context.cpp inkscape-0.47/src/eraser-context.cpp
---- inkscape-0.47-orig/src/eraser-context.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/eraser-context.cpp 2010-02-18 08:46:26.000000000 -0500
-@@ -749,7 +749,7 @@
- if ( eraserMode ) {
- toWorkOn = sp_document_partial_items_in_box(sp_desktop_document(desktop), desktop->dkey, bounds);
- } else {
-- Inkscape::Rubberband::Rubberband *r = Inkscape::Rubberband::get(desktop);
-+ Inkscape::Rubberband *r = Inkscape::Rubberband::get(desktop);
- toWorkOn = sp_document_items_at_points(sp_desktop_document(desktop), desktop->dkey, r->getPoints());
- }
- toWorkOn = g_slist_remove( toWorkOn, acid );
-diff -Naur inkscape-0.47-orig/src/extension/internal/filter/filter-file.cpp inkscape-0.47/src/extension/internal/filter/filter-file.cpp
---- inkscape-0.47-orig/src/extension/internal/filter/filter-file.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/extension/internal/filter/filter-file.cpp 2010-02-18 09:07:54.000000000 -0500
-@@ -161,7 +161,7 @@
- mywriter writer;
- sp_repr_write_stream(node, writer, 0, FALSE, g_quark_from_static_string("svg"), 0, 0);
-
-- Inkscape::Extension::build_from_mem(xml_str, new Filter::Filter(g_strdup(writer.c_str())));
-+ Inkscape::Extension::build_from_mem(xml_str, new Filter(g_strdup(writer.c_str())));
- g_free(xml_str);
- return;
- }
-diff -Naur inkscape-0.47-orig/src/extension/internal/filter/filter.cpp inkscape-0.47/src/extension/internal/filter/filter.cpp
---- inkscape-0.47-orig/src/extension/internal/filter/filter.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/extension/internal/filter/filter.cpp 2010-02-18 09:21:06.000000000 -0500
-@@ -217,7 +217,7 @@
- "<menu-tip>%s</menu-tip>\n"
- "</effect>\n"
- "</inkscape-extension>\n", name, id, submenu, tip);
-- Inkscape::Extension::build_from_mem(xml_str, new Filter::Filter(filter));
-+ Inkscape::Extension::build_from_mem(xml_str, new Filter(filter));
- g_free(xml_str);
- return;
- }
-diff -Naur inkscape-0.47-orig/src/flood-context.cpp inkscape-0.47/src/flood-context.cpp
---- inkscape-0.47-orig/src/flood-context.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/flood-context.cpp 2010-02-18 08:48:16.000000000 -0500
-@@ -900,7 +900,7 @@
- if (is_point_fill) {
- fill_points.push_back(Geom::Point(event->button.x, event->button.y));
- } else {
-- Inkscape::Rubberband::Rubberband *r = Inkscape::Rubberband::get(desktop);
-+ Inkscape::Rubberband *r = Inkscape::Rubberband::get(desktop);
- fill_points = r->getPoints();
- }
-
-@@ -1206,7 +1206,7 @@
-
- case GDK_BUTTON_RELEASE:
- if (event->button.button == 1 && !event_context->space_panning) {
-- Inkscape::Rubberband::Rubberband *r = Inkscape::Rubberband::get(desktop);
-+ Inkscape::Rubberband *r = Inkscape::Rubberband::get(desktop);
- if (r->is_started()) {
- // set "busy" cursor
- desktop->setWaitingCursor();
-diff -Naur inkscape-0.47-orig/src/gradient-context.cpp inkscape-0.47/src/gradient-context.cpp
---- inkscape-0.47-orig/src/gradient-context.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/gradient-context.cpp 2010-02-18 08:47:33.000000000 -0500
-@@ -641,7 +641,7 @@
- if (!event_context->within_tolerance) {
- // we've been dragging, either do nothing (grdrag handles that),
- // or rubberband-select if we have rubberband
-- Inkscape::Rubberband::Rubberband *r = Inkscape::Rubberband::get(desktop);
-+ Inkscape::Rubberband *r = Inkscape::Rubberband::get(desktop);
- if (r->is_started() && !event_context->within_tolerance) {
- // this was a rubberband drag
- if (r->getMode() == RUBBERBAND_MODE_RECT) {
-diff -Naur inkscape-0.47-orig/src/select-context.cpp inkscape-0.47/src/select-context.cpp
---- inkscape-0.47-orig/src/select-context.cpp 2010-02-18 08:45:58.000000000 -0500
-+++ inkscape-0.47/src/select-context.cpp 2010-02-18 08:50:11.000000000 -0500
-@@ -602,7 +602,7 @@
- }
- sc->item = NULL;
- } else {
-- Inkscape::Rubberband::Rubberband *r = Inkscape::Rubberband::get(desktop);
-+ Inkscape::Rubberband *r = Inkscape::Rubberband::get(desktop);
- if (r->is_started() && !within_tolerance) {
- // this was a rubberband drag
- GSList *items = NULL;
diff --git a/media-gfx/inkscape/files/inkscape-0.47-poppler.patch b/media-gfx/inkscape/files/inkscape-0.47-poppler.patch
deleted file mode 100644
index 304ecc8e0dc5..000000000000
--- a/media-gfx/inkscape/files/inkscape-0.47-poppler.patch
+++ /dev/null
@@ -1,110 +0,0 @@
-Fix Rawhide build (more recent poppler)
-
-Lubomir Rintel <lkundrak@v3.sk>
-
-
-Index: inkscape-svn/src/extension/internal/pdfinput/pdf-parser.cpp
-===================================================================
---- inkscape-svn/src/extension/internal/pdfinput/pdf-parser.cpp (revision 22620)
-+++ inkscape-svn/src/extension/internal/pdfinput/pdf-parser.cpp (working copy)
-@@ -56,6 +56,13 @@
- #define M_PI 3.14159265358979323846
- #endif
-
-+#include <glib/poppler-features.h>
-+#if POPPLER_CHECK_VERSION(0,12,2)
-+#define PGFX ,NULL
-+#else
-+#define PGFX
-+#endif
-+
- //------------------------------------------------------------------------
- // constants
- //------------------------------------------------------------------------
-@@ -809,7 +816,7 @@
- blendingColorSpace = NULL;
- isolated = knockout = gFalse;
- if (!obj4.dictLookup(const_cast<char*>("CS"), &obj5)->isNull()) {
-- blendingColorSpace = GfxColorSpace::parse(&obj5);
-+ blendingColorSpace = GfxColorSpace::parse(&obj5 PGFX);
- }
- obj5.free();
- if (obj4.dictLookup(const_cast<char*>("I"), &obj5)->isBool()) {
-@@ -1009,9 +1016,9 @@
- state->setFillPattern(NULL);
- res->lookupColorSpace(args[0].getName(), &obj);
- if (obj.isNull()) {
-- colorSpace = GfxColorSpace::parse(&args[0]);
-+ colorSpace = GfxColorSpace::parse(&args[0] PGFX);
- } else {
-- colorSpace = GfxColorSpace::parse(&obj);
-+ colorSpace = GfxColorSpace::parse(&obj PGFX);
- }
- obj.free();
- if (colorSpace) {
-@@ -1032,9 +1039,9 @@
- state->setStrokePattern(NULL);
- res->lookupColorSpace(args[0].getName(), &obj);
- if (obj.isNull()) {
-- colorSpace = GfxColorSpace::parse(&args[0]);
-+ colorSpace = GfxColorSpace::parse(&args[0] PGFX);
- } else {
-- colorSpace = GfxColorSpace::parse(&obj);
-+ colorSpace = GfxColorSpace::parse(&obj PGFX);
- }
- obj.free();
- if (colorSpace) {
-@@ -1101,7 +1108,7 @@
- builder->updateStyle(state);
- }
- if (args[numArgs-1].isName() &&
-- (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
-+ (pattern = res->lookupPattern(args[numArgs-1].getName() PGFX))) {
- state->setFillPattern(pattern);
- builder->updateStyle(state);
- }
-@@ -1145,7 +1152,7 @@
- builder->updateStyle(state);
- }
- if (args[numArgs-1].isName() &&
-- (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
-+ (pattern = res->lookupPattern(args[numArgs-1].getName() PGFX))) {
- state->setStrokePattern(pattern);
- builder->updateStyle(state);
- }
-@@ -1543,7 +1550,7 @@
- double *matrix = NULL;
- GBool savedState = gFalse;
-
-- if (!(shading = res->lookupShading(args[0].getName()))) {
-+ if (!(shading = res->lookupShading(args[0].getName() PGFX))) {
- return;
- }
-
-@@ -2507,7 +2514,7 @@
- }
- }
- if (!obj1.isNull()) {
-- colorSpace = GfxColorSpace::parse(&obj1);
-+ colorSpace = GfxColorSpace::parse(&obj1 PGFX);
- } else if (csMode == streamCSDeviceGray) {
- colorSpace = new GfxDeviceGrayColorSpace();
- } else if (csMode == streamCSDeviceRGB) {
-@@ -2592,7 +2599,7 @@
- obj2.free();
- }
- }
-- maskColorSpace = GfxColorSpace::parse(&obj1);
-+ maskColorSpace = GfxColorSpace::parse(&obj1 PGFX);
- obj1.free();
- if (!maskColorSpace || maskColorSpace->getMode() != csDeviceGray) {
- goto err1;
-@@ -2767,7 +2774,7 @@
- if (obj1.dictLookup(const_cast<char*>("S"), &obj2)->isName(const_cast<char*>("Transparency"))) {
- transpGroup = gTrue;
- if (!obj1.dictLookup(const_cast<char*>("CS"), &obj3)->isNull()) {
-- blendingColorSpace = GfxColorSpace::parse(&obj3);
-+ blendingColorSpace = GfxColorSpace::parse(&obj3 PGFX);
- }
- obj3.free();
- if (obj1.dictLookup(const_cast<char*>("I"), &obj3)->isBool()) {
diff --git a/media-gfx/inkscape/files/inkscape-0.48.0-libwpd.patch b/media-gfx/inkscape/files/inkscape-0.48.0-libwpd.patch
deleted file mode 100644
index 94b317f57ae1..000000000000
--- a/media-gfx/inkscape/files/inkscape-0.48.0-libwpd.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- inkscape-0.48.0/configure.ac
-+++ inkscape-0.48.0/configure.ac
-@@ -678,7 +678,7 @@
- dnl Check for libwpg for extension
- dnl ******************************
-
--PKG_CHECK_MODULES(LIBWPG, libwpg-0.1 libwpg-stream-0.1, with_libwpg=yes, with_libwpg=no)
-+PKG_CHECK_MODULES(LIBWPG, libwpg-0.2 libwpd-0.9 libwpd-stream-0.9, with_libwpg=yes, with_libwpg=no)
- if test "x$with_libwpg" = "xyes"; then
- AC_DEFINE(WITH_LIBWPG,1,[Build in libwpg])
- fi
---- inkscape-0.48.0/src/extension/internal/wpg-input.cpp
-+++ inkscape-0.48.0/src/extension/internal/wpg-input.cpp
-@@ -49,7 +49,7 @@
- #include "document.h"
-
- #include "libwpg/libwpg.h"
--#include "libwpg/WPGStreamImplementation.h"
-+#include "libwpd-stream/libwpd-stream.h"
-
-
- using namespace libwpg;
-@@ -61,9 +61,9 @@
-
- SPDocument *
- WpgInput::open(Inkscape::Extension::Input * mod, const gchar * uri) {
-- WPXInputStream* input = new libwpg::WPGFileStream(uri);
-+ WPXInputStream* input = new WPXFileStream(uri);
- if (input->isOLEStream()) {
-- WPXInputStream* olestream = input->getDocumentOLEStream();
-+ WPXInputStream* olestream = input->getDocumentOLEStream("PerfectOffice_MAIN");
- if (olestream) {
- delete input;
- input = olestream;
-@@ -78,7 +78,7 @@
- return NULL;
- }
-
-- libwpg::WPGString output;
-+ WPXString output;
- if (!libwpg::WPGraphics::generateSVG(input, output)) {
- delete input;
- return NULL;
-
-
diff --git a/media-gfx/inkscape/files/inkscape-0.48.0-poppler-0.16.patch b/media-gfx/inkscape/files/inkscape-0.48.0-poppler-0.16.patch
deleted file mode 100644
index 25327d9d1736..000000000000
--- a/media-gfx/inkscape/files/inkscape-0.48.0-poppler-0.16.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-=== modified file 'configure.ac'
---- configure.ac 2010-11-15 01:32:59 +0000
-+++ configure.ac 2010-11-21 12:38:01 +0000
-@@ -611,11 +611,12 @@
- AC_DEFINE(POPPLER_NEW_GFXFONT, 1, [Use GfxFont from Poppler >= 0.8.3])
- fi
-
--AC_MSG_CHECKING(for new color space API in Poppler)
- ink_svd_CPPFLAGS=$CPPFLAGS
- ink_svd_LIBS=$LIBS
- CPPFLAGS="$CPPFLAGS $POPPLER_CFLAGS"
- LIBS="$LIBS $POPPLER_LIBS"
-+
-+AC_MSG_CHECKING(for new color space API in Poppler)
- popplercolor="no"
- AC_COMPILE_IFELSE([
- #include <GfxState.h>
-@@ -627,16 +628,36 @@
- return 0;
- }
- ], [popplercolor=yes])
-+if test "x$popplercolor" = "xyes"; then
-+ AC_DEFINE(POPPLER_NEW_COLOR_SPACE_API, 1, [Use color space API from Poppler >= 0.12.2])
-+ AC_MSG_RESULT(yes)
-+else
-+ AC_MSG_RESULT(no)
-+fi
-+
-+# Poppler's b604a008 commit changes this
-+AC_MSG_CHECKING([whether Poppler's GfxPatch no longer uses GfxColor])
-+popplergfxcolor="no"
-+AC_COMPILE_IFELSE([
-+#include <GfxState.h>
-+
-+int main() {
-+ GfxPatch::ColorValue color = {c: {0}};
-+ GfxPatch patch;
-+ patch.color[[0]][[0]] = color;
-+ return 0;
-+}
-+], [popplergfxcolor=yes])
-+if test "x$popplergfxcolor" = "xyes"; then
-+ AC_DEFINE(POPPLER_NEW_GFXPATCH, 1, [GfxPatch no longer uses GfxColor in >= 0.15.1])
-+ AC_MSG_RESULT(yes)
-+else
-+ AC_MSG_RESULT(no)
-+fi
-+
- CPPFLAGS=$ink_svd_CPPFLAGS
- LIBS=$ink_svd_LIBS
-
--if test "x$popplercolor" = "xyes"; then
-- AC_DEFINE(POPPLER_NEW_COLOR_SPACE_API, 1, [Use color space API from Poppler >= 0.12.2])
-- AC_MSG_RESULT(yes)
--else
-- AC_MSG_RESULT(no)
--fi
--
- dnl ******************************
- dnl Inkboard dependency checking
- dnl ******************************
-
-=== modified file 'src/extension/internal/pdfinput/pdf-parser.cpp'
---- src/extension/internal/pdfinput/pdf-parser.cpp 2010-03-21 01:53:59 +0000
-+++ src/extension/internal/pdfinput/pdf-parser.cpp 2010-11-21 12:38:01 +0000
-@@ -1874,6 +1874,9 @@
-
- void PdfParser::fillPatch(GfxPatch *patch, int nComps, int depth) {
- GfxPatch patch00, patch01, patch10, patch11;
-+#ifdef POPPLER_NEW_GFXPATCH
-+ GfxColor color;
-+#endif
- double xx[4][8], yy[4][8];
- double xxm, yym;
- double patchColorDelta = colorDeltas[pdfPatchMeshShading-1];
-@@ -1890,9 +1893,16 @@
- > patchColorDelta) {
- break;
- }
-+#ifdef POPPLER_NEW_GFXPATCH
-+ color.c[i] = GfxColorComp(patch->color[0][0].c[i]);
-+#endif
- }
- if (i == nComps || depth == maxDepths[pdfPatchMeshShading-1]) {
-+#ifdef POPPLER_NEW_GFXPATCH
-+ state->setFillColor(&color);
-+#else
- state->setFillColor(&patch->color[0][0]);
-+#endif
- state->moveTo(patch->x[0][0], patch->y[0][0]);
- state->curveTo(patch->x[0][1], patch->y[0][1],
- patch->x[0][2], patch->y[0][2],
-