summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2009-02-14 16:40:36 +0000
committerCarsten Lohrke <carlo@gentoo.org>2009-02-14 16:40:36 +0000
commit51f56f740a79f70d05f597b8a98ac638ed36636b (patch)
treefb82080a4608f8124d4a361123fe8948dc317f5b /media-gfx/kst
parentChange ebuild to express use dependencies properly. (diff)
downloadhistorical-51f56f740a79f70d05f597b8a98ac638ed36636b.tar.gz
historical-51f56f740a79f70d05f597b8a98ac638ed36636b.tar.bz2
historical-51f56f740a79f70d05f597b8a98ac638ed36636b.zip
Version bump. Get rid of invalid aRts dependency. Fix desktop file.
Package-Manager: portage-2.2_rc23/cvs/Linux i686
Diffstat (limited to 'media-gfx/kst')
-rw-r--r--media-gfx/kst/ChangeLog10
-rw-r--r--media-gfx/kst/files/kst-1.7.0-desktop-file.diff36
-rw-r--r--media-gfx/kst/kst-1.7.0.ebuild26
3 files changed, 70 insertions, 2 deletions
diff --git a/media-gfx/kst/ChangeLog b/media-gfx/kst/ChangeLog
index ebf56ce36496..8e8a0a3d621e 100644
--- a/media-gfx/kst/ChangeLog
+++ b/media-gfx/kst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/kst
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/kst/ChangeLog,v 1.19 2008/06/26 13:58:51 markusle Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/kst/ChangeLog,v 1.20 2009/02/14 16:40:36 carlo Exp $
+
+*kst-1.7.0 (14 Feb 2009)
+
+ 14 Feb 2009; Carsten Lohrke <carlo@gentoo.org>
+ +files/kst-1.7.0-desktop-file.diff, +kst-1.7.0.ebuild:
+ Version bump. Get rid of invalid aRts dependency. Fix desktop file.
*kst-1.6.0 (26 Jun 2008)
diff --git a/media-gfx/kst/files/kst-1.7.0-desktop-file.diff b/media-gfx/kst/files/kst-1.7.0-desktop-file.diff
new file mode 100644
index 000000000000..9a0d99645986
--- /dev/null
+++ b/media-gfx/kst/files/kst-1.7.0-desktop-file.diff
@@ -0,0 +1,36 @@
+--- kst/src/kst/Makefile.am.o 2009-02-14 16:45:24.000000000 +0100
++++ kst/src/kst/Makefile.am 2009-02-14 16:47:32.000000000 +0100
+@@ -14,10 +14,7 @@
+ servicesdir = $(kde_servicetypesdir)/kst
+ services_DATA = kstplugin.desktop kstdatasourceplugin.desktop kstdataobjectplugin.desktop kstbasicplugin.desktop kstfilter.desktop kstextension.desktop
+
+-appsinstalldir = $(datadir)/applications
+-appsinstall_DATA = kst.desktop
+-
+-appsdir = $(kde_appsdir)/Graphics
++appsdir = $(xdg_appsdir)
+ apps_DATA = kst.desktop
+
+ mimedir = $(kde_mimedir)/application
+--- kst/src/kst/kst.desktop.o 2009-02-14 16:48:33.000000000 +0100
++++ kst/src/kst/kst.desktop 2009-02-14 16:50:17.000000000 +0100
+@@ -1,10 +1,10 @@
+ [Desktop Entry]
+ Type=Application
+-Exec=kst -caption "%c" %i %m
++Exec=kst -caption "%c" %i
+ Icon=kst
+-DocPath=kst/index.html
++X-DocPath=kst/index.html
+ MimeType=application/x-kst;
+-Categories=Qt;KDE;Utility;X-KDE-Science;
++Categories=Qt;KDE;Utility;Education;Science;DataVisualization;X-KDE-Science;
+ X-DCOP-ServiceType=Multi
+ X-KDE-StartupNotify=false
+ Name=Kst
+@@ -44,5 +44,3 @@
+ GenericName[vi]=Bộ xem dữ liệu
+ GenericName[xx]=xxData Viewerxx
+ GenericName[zh_CN]=数据查看器
+-
+-Encoding=UTF-8
diff --git a/media-gfx/kst/kst-1.7.0.ebuild b/media-gfx/kst/kst-1.7.0.ebuild
new file mode 100644
index 000000000000..ee216ae7629a
--- /dev/null
+++ b/media-gfx/kst/kst-1.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/kst/kst-1.7.0.ebuild,v 1.1 2009/02/14 16:40:36 carlo Exp $
+
+ARTS_REQUIRED="never"
+
+inherit kde
+
+DESCRIPTION="A plotting and data viewing program for KDE."
+HOMEPAGE="http://kst.kde.org/"
+SRC_URI="mirror://kde/stable/apps/KDE3.x/scientific/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="sci-libs/gsl
+ >=sci-libs/netcdf-3.6.1-r1"
+RDEPEND="${DEPEND}"
+
+need-kde 3.5
+
+PATCHES=(
+ "${FILESDIR}/kst-1.7.0-desktop-file.diff"
+ )