summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2010-04-07 17:04:04 +0000
committerBenedikt Boehm <hollow@gentoo.org>2010-04-07 17:04:04 +0000
commite0e96d03b3fb048938902f8c2428fb13ed03da0e (patch)
tree16d8e522ba887cf1a34f103350196805629327d1 /media-gfx/shotwell
parentFixing xen-tools-3.4.0-network-bridge-broadcast.patch for #258378 (diff)
downloadhistorical-e0e96d03b3fb048938902f8c2428fb13ed03da0e.tar.gz
historical-e0e96d03b3fb048938902f8c2428fb13ed03da0e.tar.bz2
historical-e0e96d03b3fb048938902f8c2428fb13ed03da0e.zip
initial ebuild wrt #309615
Package-Manager: portage-2.2_rc67/cvs/Linux i686
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/ChangeLog10
-rw-r--r--media-gfx/shotwell/Manifest4
-rw-r--r--media-gfx/shotwell/metadata.xml11
-rw-r--r--media-gfx/shotwell/shotwell-0.5.0.ebuild48
4 files changed, 73 insertions, 0 deletions
diff --git a/media-gfx/shotwell/ChangeLog b/media-gfx/shotwell/ChangeLog
new file mode 100644
index 000000000000..e6d6f1bd3576
--- /dev/null
+++ b/media-gfx/shotwell/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-gfx/shotwell
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/ChangeLog,v 1.1 2010/04/07 17:04:04 hollow Exp $
+
+*shotwell-0.5.0 (07 Apr 2010)
+
+ 07 Apr 2010; Benedikt Böhm <hollow@gentoo.org> +shotwell-0.5.0.ebuild,
+ +metadata.xml:
+ initial ebuild wrt #309615
+
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
new file mode 100644
index 000000000000..a6aa7692336f
--- /dev/null
+++ b/media-gfx/shotwell/Manifest
@@ -0,0 +1,4 @@
+DIST shotwell-0.5.0.tar.bz2 525555 RMD160 0b8d73afe58859915ce3fda9d77224ac5317f262 SHA1 818d50faea5323192b51749ee1331966c0601768 SHA256 bb02bcb464297f1e42914fc9d616202bb7cac4b12bbe2b0b390719dc5175afb4
+EBUILD shotwell-0.5.0.ebuild 1285 RMD160 3bae47d8faabc0e993e93efffd01703cd1e50c56 SHA1 99e41881e2728bae0b10b5f1f5e1f8c11dcc2762 SHA256 db7bf1d88be35855914750684c9cb3a5275c1bdc5a3316f88868c675a1f7d3cd
+MISC ChangeLog 361 RMD160 34f87d7773471f15f54cd6f0d00fe8f91612b207 SHA1 5d444770c901d79655bca015ed77e5ea45ab6548 SHA256 530222455f8426ff4e546073d88b32a150faa69c418af11b452f09d3ba00e315
+MISC metadata.xml 462 RMD160 ebdc974e779f29fa2a7ccc15b1868771313e097f SHA1 e5c4b2f1764c6dd2ce88ec9fa132611f12ff5c82 SHA256 f024cceed8c6538e626e875afe970db722f593b35cd105bf0b1a7b57b309e88a
diff --git a/media-gfx/shotwell/metadata.xml b/media-gfx/shotwell/metadata.xml
new file mode 100644
index 000000000000..cfa1881687e1
--- /dev/null
+++ b/media-gfx/shotwell/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <longdescription lang="en">
+ Shotwell is a digital photo organizer designed for the GNOME desktop
+ environment. It allows you to import photos from disk or camera, organize
+ them in various ways, view them in full-window or fullscreen mode, and
+ export them to share with others.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-gfx/shotwell/shotwell-0.5.0.ebuild b/media-gfx/shotwell/shotwell-0.5.0.ebuild
new file mode 100644
index 000000000000..ec9f43231e8a
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.5.0.ebuild,v 1.1 2010/04/07 17:04:04 hollow Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="http://www.yorba.org/shotwell/"
+SRC_URI="http://www.yorba.org/download/${PN}/${MY_PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/sqlite-3.5.9:3
+ >=dev-libs/dbus-glib-0.80
+ >=dev-libs/libgee-0.5.0
+ >=dev-libs/libunique-1.0.0
+ >=dev-libs/libxml2-2.6.32
+ >=gnome-base/gconf-2.22.0
+ >=media-libs/libexif-0.6.16
+ >=media-libs/libgphoto2-2.4.2
+ >=net-libs/libsoup-2.26.0
+ >=net-libs/webkit-gtk-1.1.5
+ >=sys-fs/udev-145[extras]
+ >=x11-libs/gtk+-2.14.4:2"
+DEPEND="${RDEPEND}
+ =dev-lang/vala-0.7*"
+
+DOCS="AUTHORS MAINTAINERS NEWS README THANKS"
+
+pkg_setup() {
+ G2CONF="--disable-schemas-install \
+ --disable-desktop-update \
+ --disable-icon-update"
+}
+
+src_install() {
+ # This is needed so that gnome2_gconf_savelist() works correctly.
+ insinto "${EPREFIX}"/etc/gconf/schemas
+ doins misc/shotwell.schemas || die "install gconf schema failed"
+ gnome2_src_install
+}