summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-27 16:20:46 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-27 16:20:46 +0000
commit279a2584521125d323ea5dc645688b5370b47aa1 (patch)
tree6d84ec581c1c3272273f948d952c0c2dd9aa7578 /media-gfx
parent*** empty log message *** (diff)
downloadhistorical-279a2584521125d323ea5dc645688b5370b47aa1.tar.gz
historical-279a2584521125d323ea5dc645688b5370b47aa1.tar.bz2
historical-279a2584521125d323ea5dc645688b5370b47aa1.zip
*** empty log message ***
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gimp-print/gimp-print-4.0.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/gimp-print/gimp-print-4.0.3.ebuild b/media-gfx/gimp-print/gimp-print-4.0.3.ebuild
new file mode 100644
index 000000000000..d257142e97ab
--- /dev/null
+++ b/media-gfx/gimp-print/gimp-print-4.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.0.3.ebuild,v 1.1 2000/11/27 16:20:46 achim Exp $
+
+A=print-${PV}.tar.gz
+S=${WORKDIR}/print-${PV}
+DESCRIPTION="Gimp Plugin and Ghostscript driver for Gimp"
+SRC_URI="http://download.sourceforge.net/gimp-print/"${A}
+HOMEPAGE="http://gimp-print.sourceforge.net/"
+
+DEPEND=">=media-gfx/gimp-1.1.29"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 \
+ --with-gimp-exec-prefix=/usr/X11R6
+ cp Makefile Makefile.orig
+ sed -e "s:^libexecdir = :libexecdir = ${D}/: " \
+ Makefile.orig > Makefile
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install-binPROGRAMS
+ insinto /usr/X11R6/lib/gimp/1.1/plug-ins/
+ insopts -m755
+ doins print
+ dodoc AUTHORS ChangeLog COPYING NEWS README* RELNOTES
+}
+
+
+
+
+