summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-05 21:24:31 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-05 21:24:31 +0000
commit6a5137aa7944976cd39d2b2c2f4586ef7938d8d2 (patch)
tree94f3d430a7aa63c8727fd1f879df1254653c0439 /media-gfx
parentversion bump (diff)
downloadhistorical-6a5137aa7944976cd39d2b2c2f4586ef7938d8d2.tar.gz
historical-6a5137aa7944976cd39d2b2c2f4586ef7938d8d2.tar.bz2
historical-6a5137aa7944976cd39d2b2c2f4586ef7938d8d2.zip
New version
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gimp/ChangeLog7
-rw-r--r--media-gfx/gimp/files/digest-gimp-1.3.111
-rw-r--r--media-gfx/gimp/gimp-1.3.11.ebuild71
3 files changed, 78 insertions, 1 deletions
diff --git a/media-gfx/gimp/ChangeLog b/media-gfx/gimp/ChangeLog
index a15c14aaa52c..96d4a059bb43 100644
--- a/media-gfx/gimp/ChangeLog
+++ b/media-gfx/gimp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/gimp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.17 2002/12/29 04:43:01 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.18 2003/01/05 21:24:31 foser Exp $
+
+*gimp-1.3.11 (05 Jan 2003)
+
+ 05 Jan 2003; foser <foser@gentoo.org> gimp-1.3.11.ebuild :
+ New devel version, the python plugin seems stabilized
*gimp-1.3.10 (08 Nov 2002)
diff --git a/media-gfx/gimp/files/digest-gimp-1.3.11 b/media-gfx/gimp/files/digest-gimp-1.3.11
new file mode 100644
index 000000000000..48b0db9db9e5
--- /dev/null
+++ b/media-gfx/gimp/files/digest-gimp-1.3.11
@@ -0,0 +1 @@
+MD5 df2e753e1ad951b52f790b8392091a46 gimp-1.3.11.tar.bz2 9736877
diff --git a/media-gfx/gimp/gimp-1.3.11.ebuild b/media-gfx/gimp/gimp-1.3.11.ebuild
new file mode 100644
index 000000000000..6b406cee258d
--- /dev/null
+++ b/media-gfx/gimp/gimp-1.3.11.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.11.ebuild,v 1.1 2003/01/05 21:24:31 foser Exp $
+
+IUSE="doc python"
+
+inherit debug
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Development series of Gimp"
+SRC_URI="ftp://ftp.gimp.org/pub/gimp/v1.3/v${PV}/${P}.tar.bz2"
+HOMEPAGE="http://www.gimp.org/"
+SLOT="1.4"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+#libglade
+RDEPEND=">=x11-libs/gtk+-2.0.0
+ >=x11-libs/pango-1.0.0
+ >=dev-libs/glib-2.0.0
+ >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/tiff-3.5.7
+ >=media-libs/libart_lgpl-2.3.8-r1
+ sys-devel/gettext
+ python? ( >=dev-lang/python-2.2 )"
+
+# Bah, circ dependency
+# cups? ( media-gfx/gimp-print )
+
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_compile() {
+ local myconf
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+
+ use python \
+ && myconf="${myconf} --enable-python" \
+ || myconf="${myconf} --disable-python"
+
+ myconf="${myconf} --disable-print"
+
+ econf --disable-perl ${myconf} --without-gnome-desktop || die
+ # disable gnome-desktop since it breaks sandboxing
+
+ # hack for odd make break
+ touch plug-ins/common/${P}.tar.bz2
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ localstatedir=/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeL* HACKING INSTALL MAINTAINERS NEWS PLUGIN_MAINTAINERS README* TODO*
+}
+
+
+pkg_postinst() {
+ ewarn "There have been changes to the gtkrc file."
+ ewarn "You are strongly advised to remove the ~/.gimp-1.3 directory and perform a fresh"
+ ewarn "user installation if you have been running a gimp-1.3 below minor version 11"
+}