summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-05-06 17:27:21 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-05-06 17:27:21 +0000
commitc976c0de6fb602c1392d9d9ad8df0cdc51cc30a7 (patch)
tree9945bc79f959727348e95f0c83e889afb562ca61 /media-gfx
parentnew version (diff)
downloadhistorical-c976c0de6fb602c1392d9d9ad8df0cdc51cc30a7.tar.gz
historical-c976c0de6fb602c1392d9d9ad8df0cdc51cc30a7.tar.bz2
historical-c976c0de6fb602c1392d9d9ad8df0cdc51cc30a7.zip
new version
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/imagemagick/ChangeLog4
-rw-r--r--media-gfx/imagemagick/files/digest-imagemagick-5.4.51
-rw-r--r--media-gfx/imagemagick/imagemagick-5.4.5.ebuild78
3 files changed, 82 insertions, 1 deletions
diff --git a/media-gfx/imagemagick/ChangeLog b/media-gfx/imagemagick/ChangeLog
index df945f900fd6..9fd958ecf466 100644
--- a/media-gfx/imagemagick/ChangeLog
+++ b/media-gfx/imagemagick/ChangeLog
@@ -1,6 +1,8 @@
# ChangeLog for media-gfx/imagemagick
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.10 2002/04/29 08:47:19 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/ChangeLog,v 1.11 2002/05/06 17:27:21 azarah Exp $
+
+*imagemagick-5.4.5 (6 May 2002)
29 Apr 2002; Thilo Bangert <bangert@gentoo.org> imagemagick-5.4.4-r2.ebuild :
diff --git a/media-gfx/imagemagick/files/digest-imagemagick-5.4.5 b/media-gfx/imagemagick/files/digest-imagemagick-5.4.5
new file mode 100644
index 000000000000..31b8ca6f0f8d
--- /dev/null
+++ b/media-gfx/imagemagick/files/digest-imagemagick-5.4.5
@@ -0,0 +1 @@
+MD5 b92fbc5fd662e790af0363ba4338dc0b ImageMagick-5.4.5-1.tar.gz 3874047
diff --git a/media-gfx/imagemagick/imagemagick-5.4.5.ebuild b/media-gfx/imagemagick/imagemagick-5.4.5.ebuild
new file mode 100644
index 000000000000..ffa09772239b
--- /dev/null
+++ b/media-gfx/imagemagick/imagemagick-5.4.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/imagemagick/imagemagick-5.4.5.ebuild,v 1.1 2002/05/06 17:27:21 azarah Exp $
+
+MY_PN=ImageMagick
+MY_P=${MY_PN}-${PV}-1
+S=${WORKDIR}/${MY_PN}-${PV}
+DESCRIPTION="A collection of tools and libraries for many image formats"
+SRC_URI="http://imagemagick.sourceforge.net/http/${MY_P}.tar.gz"
+HOMEPAGE="http://www.imagemagick.org/"
+SLOT="0"
+
+DEPEND="X? ( virtual/x11
+ >=app-text/dgs-0.5.9.1 )
+ >=sys-apps/bzip2-1
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/freetype-2.0
+ >=media-libs/jpeg-6b
+ >=media-libs/tiff-3.5.5
+ media-libs/libpng
+ gs? ( >=app-text/ghostscript-6.50 )
+ lcms? ( >=media-libs/lcms-1.06 )
+ perl? ( >=sys-devel/perl-5 )
+ xml2? ( >=dev-libs/libxml2-2.4.10 )"
+
+
+src_compile() {
+ libtoolize --copy --force
+
+ local myconf=""
+ use perl || myconf="--without-perl"
+ use lcms || myconf="${myconf} --without-lcms"
+ use xml2 || myconf="${myconf} --without-xml"
+ use X || myconf="${myconf} --with-x=no"
+
+ # Netscape is still used ? More people should have Mozilla
+ cp configure configure.orig
+ sed -e 's:netscape:mozilla:g' configure.orig > configure
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-shared \
+ --enable-static \
+ --enable-lzw \
+ --with-ttf \
+ --without-fpx \
+ --without-gslib \
+ --without-hdf \
+ --without-jbig \
+ --without-wmf \
+ --with-threads \
+ --build=${CHOST} \
+ ${myconf} || die "bad configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ PREFIX=${D}/usr \
+ INSTALLPRIVLIB=${D}/usr/lib/perl5 \
+ INSTALLSCRIPT=${D}/usr/bin \
+ INSTALLSITELIB=${D}/usr/lib/perl5/site_perl \
+ INSTALLBIN=${D}/usr/bin \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ mandir=${D}/usr/share/man \
+ MagickSharePath=${D}/usr/share/ImageMagick/ \
+ pkgdocdir=${D}/usr/share/doc/${PF}/html \
+ install || die "install problem"
+
+ rm -f ${D}/usr/share/ImageMagick/*.txt
+
+ dodoc Copyright.txt PLATFORMS.txt QuickStart.txt README.txt TODO.txt
+}
+