summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-03-17 20:37:22 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-03-17 20:37:22 +0000
commitf2c237ae1e46c57ab8357c104446583291385402 (patch)
treea90baba044f41e968eed326946298a321116b458 /media-libs/alsa-lib/alsa-lib-1.0.14_rc3.ebuild
parentVersion bump. Thanks to Diego Pettenò <flameeyes@gmail.com>. (diff)
downloadhistorical-f2c237ae1e46c57ab8357c104446583291385402.tar.gz
historical-f2c237ae1e46c57ab8357c104446583291385402.tar.bz2
historical-f2c237ae1e46c57ab8357c104446583291385402.zip
Version bump. Thanks to Diego Pettenò <flameeyes@gmail.com>.
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'media-libs/alsa-lib/alsa-lib-1.0.14_rc3.ebuild')
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.14_rc3.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.14_rc3.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.14_rc3.ebuild
new file mode 100644
index 000000000000..c709fed8ae50
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.14_rc3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.14_rc3.ebuild,v 1.1 2007/03/17 20:37:21 betelgeuse Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug"
+
+RDEPEND=">=media-sound/alsa-headers-${PV}"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_with debug) \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ elog ""
+ elog "Please try media-sound/alsa-driver before filing bugs about unstable"
+ elog "or missing output with in-kernel drivers. Misaligned versions of"
+ elog "alsa-lib and drivers used can cause problems."
+}