summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-04-11 17:10:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-04-11 17:10:42 +0000
commitc9a40ab0e82b16330434b17c7fa3ced0f25d1f53 (patch)
tree4c54aebdfeab19896f283da5a9b60e60bd193f18 /media-libs/alure/alure-1.1.ebuild
parentppc64 stable wrt #361401 (diff)
downloadhistorical-c9a40ab0e82b16330434b17c7fa3ced0f25d1f53.tar.gz
historical-c9a40ab0e82b16330434b17c7fa3ced0f25d1f53.tar.bz2
historical-c9a40ab0e82b16330434b17c7fa3ced0f25d1f53.zip
Version bump.
Package-Manager: portage-2.2.0_alpha29/cvs/Linux x86_64
Diffstat (limited to 'media-libs/alure/alure-1.1.ebuild')
-rw-r--r--media-libs/alure/alure-1.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/alure/alure-1.1.ebuild b/media-libs/alure/alure-1.1.ebuild
new file mode 100644
index 000000000000..496f97ed61e4
--- /dev/null
+++ b/media-libs/alure/alure-1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alure/alure-1.1.ebuild,v 1.1 2011/04/11 17:10:42 ssuominen Exp $
+
+EAPI=2
+inherit cmake-utils
+
+DESCRIPTION="The OpenAL Utility Toolkit"
+HOMEPAGE="http://kcat.strangesoft.net/alure.html"
+SRC_URI="http://kcat.strangesoft.net/alure-releases/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dumb flac fluidsynth mp3 sndfile static-libs vorbis"
+
+RDEPEND=">=media-libs/openal-1.1
+ dumb? ( media-libs/dumb )
+ flac? ( media-libs/flac )
+ fluidsynth? ( >=media-sound/fluidsynth-1.1.1 )
+ mp3? ( media-sound/mpg123 )
+ sndfile? ( media-libs/libsndfile )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "/DESTINATION/s:doc/alure:doc/${PF}:" CMakeLists.txt || die
+}
+
+src_configure() {
+ # -DMODPLUG because libmodplug has header called libmodplug/sndfile.h
+ # that conflicts with sndfile.h from libsndfile!
+ local mycmakeargs=(
+ $(cmake-utils_use dumb)
+ $(cmake-utils_use flac)
+ $(cmake-utils_use fluidsynth)
+ -DMODPLUG=OFF
+ $(cmake-utils_use mp3 MPG123)
+ $(cmake-utils_use sndfile)
+ $(cmake-utils_use_build static-libs STATIC)
+ $(cmake-utils_use vorbis)
+ )
+
+ cmake-utils_src_configure
+}