summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2008-10-07 21:34:20 +0000
committerHanno Boeck <hanno@gentoo.org>2008-10-07 21:34:20 +0000
commit2322e9512623106c6c86b7241fe17ff6cb1943f7 (patch)
tree7320ad102cea11ea3e117239aa23330a0e7da159 /media-libs/babl/babl-0.0.22.ebuild
parentVersion bump, bug #235753. (diff)
downloadhistorical-2322e9512623106c6c86b7241fe17ff6cb1943f7.tar.gz
historical-2322e9512623106c6c86b7241fe17ff6cb1943f7.tar.bz2
historical-2322e9512623106c6c86b7241fe17ff6cb1943f7.zip
added babl ebuild
Package-Manager: portage-2.2_rc11/cvs/Linux 2.6.27-rc9-00169-gb34c873 x86_64
Diffstat (limited to 'media-libs/babl/babl-0.0.22.ebuild')
-rw-r--r--media-libs/babl/babl-0.0.22.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/babl/babl-0.0.22.ebuild b/media-libs/babl/babl-0.0.22.ebuild
new file mode 100644
index 000000000000..a811092fe984
--- /dev/null
+++ b/media-libs/babl/babl-0.0.22.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-0.0.22.ebuild,v 1.1 2008/10/07 21:34:20 hanno Exp $
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+SRC_URI="ftp://ftp.gtk.org/pub/${PN}/0.0/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sse mmx"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ econf $(use_enable mmx) \
+ $(use_enable sse) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ find "${D}" -name '*.la' -delete
+ dodoc AUTHORS ChangeLog README NEWS || die "dodoc failed"
+}