summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-10-06 15:30:16 +0000
committerDan Armak <danarmak@gentoo.org>2001-10-06 15:30:16 +0000
commit3bd85fe59a6b3e886c351a2ab54572fe504b44ee (patch)
treea69267f7535d800ecdbba111fb79419bb5ab9b6c /media-libs/coin/coin-20010601-r1.ebuild
parentThe Big Commit. Modifies apps to install into /usr instead of /usr/X11R6. If ... (diff)
downloadhistorical-3bd85fe59a6b3e886c351a2ab54572fe504b44ee.tar.gz
historical-3bd85fe59a6b3e886c351a2ab54572fe504b44ee.tar.bz2
historical-3bd85fe59a6b3e886c351a2ab54572fe504b44ee.zip
The Big Commit. Modifies apps to install into /usr instead of /usr/X11R6. If it breaks, fix it.
Diffstat (limited to 'media-libs/coin/coin-20010601-r1.ebuild')
-rw-r--r--media-libs/coin/coin-20010601-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/coin/coin-20010601-r1.ebuild b/media-libs/coin/coin-20010601-r1.ebuild
new file mode 100644
index 000000000000..6e0f8618d182
--- /dev/null
+++ b/media-libs/coin/coin-20010601-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/coin/coin-20010601-r1.ebuild,v 1.1 2001/10/06 15:30:16 danarmak Exp $
+
+
+A=Coin-${PV}.tar.gz
+S=${WORKDIR}/Coin
+DESCRIPTION="An OpenSource implementation of SGI's OpenInventor"
+SRC_URI="ftp://ftp.coin3d.org/pub/snapshots/${A}"
+HOMEPAGE="http://www.coin3d.org"
+
+DEPEND="virtual/x11 virtual/opengl"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use X`" ]
+ then
+ myconf="--without-x"
+ fi
+ try ./configure --prefix=/usr --host=${CHOST} --build=${CHOST} $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr install
+ dodoc AUTHORS COPYING ChangeLog* HACKING LICENSE* NEWS README*
+ docinto txt
+ dodoc docs/*.txt docs/coin.doxygen docs/whitepapers/*.txt
+
+}
+