summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2010-08-22 05:36:39 +0000
committerRyan Hill <rhill@gentoo.org>2010-08-22 05:36:39 +0000
commitf5a37e68be68977e33f744c76785aa9106485463 (patch)
treebb5c677a24f99ca6087de673082334e7bebc0029 /media-libs/gegl/gegl-0.1.2.ebuild
parentFix cross compilation (diff)
downloadhistorical-f5a37e68be68977e33f744c76785aa9106485463.tar.gz
historical-f5a37e68be68977e33f744c76785aa9106485463.tar.bz2
historical-f5a37e68be68977e33f744c76785aa9106485463.zip
Fix buffer overflow in gegl_buffer_header_init() (bug #319789).
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'media-libs/gegl/gegl-0.1.2.ebuild')
-rw-r--r--media-libs/gegl/gegl-0.1.2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/media-libs/gegl/gegl-0.1.2.ebuild b/media-libs/gegl/gegl-0.1.2.ebuild
index ecac2e877f4f..7238f5cd0561 100644
--- a/media-libs/gegl/gegl-0.1.2.ebuild
+++ b/media-libs/gegl/gegl-0.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/gegl-0.1.2.ebuild,v 1.3 2010/02/21 07:00:51 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gegl/gegl-0.1.2.ebuild,v 1.4 2010/08/22 05:36:39 dirtyepic Exp $
EAPI="2"
@@ -36,6 +36,10 @@ DEPEND=">=media-libs/babl-0.1.2
svg? ( >=gnome-base/librsvg-2.14.0 )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buffer-overflow.patch
+}
+
src_configure() {
econf --with-gtk --with-pango --with-gdk-pixbuf \
$(use_enable debug) \