summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2003-12-28 02:20:01 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2003-12-28 02:20:01 +0000
commitae71d54e06cd5f795ea7c453b7949eb44250fdeb (patch)
tree59873aa18e25262a61898e6843ba70541dcf1880 /media-libs/libao/libao-0.8.4-r1.ebuild
parentAdded xfs support. Tweaks defconfig for more reasonable 'gentoo' defaults. (diff)
downloadhistorical-ae71d54e06cd5f795ea7c453b7949eb44250fdeb.tar.gz
historical-ae71d54e06cd5f795ea7c453b7949eb44250fdeb.tar.bz2
historical-ae71d54e06cd5f795ea7c453b7949eb44250fdeb.zip
Caught a bad case of DEPEND breakage in regression testing. This had silent deps on a lot of stuff, which are now more correctly handled. (getting more solid and working buildchains)
Removed mips from KEYWORDS because a lot of the USE flagged depends don't have mips keywords set. Fixed up USE flags for alsa, arts, nas and made the esound depend actually work as supposed. Keyworded this to the sound herd. Adding myself as maintainer.
Diffstat (limited to 'media-libs/libao/libao-0.8.4-r1.ebuild')
-rw-r--r--media-libs/libao/libao-0.8.4-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/libao/libao-0.8.4-r1.ebuild b/media-libs/libao/libao-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..fe7b667d3b65
--- /dev/null
+++ b/media-libs/libao/libao-0.8.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libao/libao-0.8.4-r1.ebuild,v 1.1 2003/12/28 02:20:01 spider Exp $
+
+IUSE="alsa arts esd nas"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="the audio output library"
+SRC_URI="http://www.xiph.org/ao/src/${P}.tar.gz"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
+# removing "mips" because of dependency breakage
+
+DEPEND="virtual/glibc
+ alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )
+ esd? ( >=media-sound/esound-0.2.22 )
+ nas? ( media-libs/nas )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src/plugins/alsa09
+ epatch ${FILESDIR}/alsa-1.0.patch
+}
+
+src_compile() {
+ econf \
+ `use_enable alsa alsa09` \
+ `use_enable arts` \
+ `use_enable esd` \
+ `use_enable nas` \
+ --enable-shared \
+ --enable-static || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ rm -rf ${D}/usr/share/doc
+ dodoc AUTHORS CHANGES COPYING README TODO
+ dohtml -A c doc/*.html
+}