summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-08-18 17:34:36 +0000
committerMax Kalika <max@gentoo.org>2003-08-18 17:34:36 +0000
commit8460259c5638bef74b5bc03eb7ef5061b9bad240 (patch)
tree3a1e28b8dea89777d9018931cf1bc496d1a010ed /media-libs/libcdaudio/libcdaudio-0.99.9.ebuild
parentfix for alpha ev67 (diff)
downloadhistorical-8460259c5638bef74b5bc03eb7ef5061b9bad240.tar.gz
historical-8460259c5638bef74b5bc03eb7ef5061b9bad240.tar.bz2
historical-8460259c5638bef74b5bc03eb7ef5061b9bad240.zip
Bump to version 0.99.9.
Diffstat (limited to 'media-libs/libcdaudio/libcdaudio-0.99.9.ebuild')
-rw-r--r--media-libs/libcdaudio/libcdaudio-0.99.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-libs/libcdaudio/libcdaudio-0.99.9.ebuild b/media-libs/libcdaudio/libcdaudio-0.99.9.ebuild
new file mode 100644
index 000000000000..336263a082b2
--- /dev/null
+++ b/media-libs/libcdaudio/libcdaudio-0.99.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libcdaudio/libcdaudio-0.99.9.ebuild,v 1.1 2003/08/18 17:34:34 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Library of cd audio related routines."
+SRC_URI="mirror://sourceforge/libcdaudio/${P}.tar.gz"
+HOMEPAGE="http://libcdaudio.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~mips"
+
+src_compile() {
+ # -fPIC is required for this library on alpha, see bug #17192
+ use alpha && append-flags -fPIC
+
+ econf --enable-threads --with-gnu-ld
+ emake || die "compile problem."
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+ dodoc AUTHORS COPYING ChangLog NEWS README README.BeOS README.OSF1 TODO
+}