summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-13 22:18:00 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-13 22:18:00 +0000
commit5b47d02fd669efcf312a0b2ca5bea9f09aeaf6ec (patch)
treec32d34bd0d30ff76d40496365ed7d01cbd0b08bf /media-libs/libdca/files
parentFix .desktop entry stuff properly, get rid of the seemingly improper patch fo... (diff)
downloadhistorical-5b47d02fd669efcf312a0b2ca5bea9f09aeaf6ec.tar.gz
historical-5b47d02fd669efcf312a0b2ca5bea9f09aeaf6ec.tar.bz2
historical-5b47d02fd669efcf312a0b2ca5bea9f09aeaf6ec.zip
Don't build tests and examples which aren't installed anyway wrt bug 226341.
Package-Manager: portage-2.1.5.5
Diffstat (limited to 'media-libs/libdca/files')
-rw-r--r--media-libs/libdca/files/libdca-0.0.5-tests-optional.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libdca/files/libdca-0.0.5-tests-optional.patch b/media-libs/libdca/files/libdca-0.0.5-tests-optional.patch
new file mode 100644
index 000000000000..0f52ac6f5c30
--- /dev/null
+++ b/media-libs/libdca/files/libdca-0.0.5-tests-optional.patch
@@ -0,0 +1,37 @@
+diff -NrU5 libdca-0.0.5.orig/configure.ac libdca-0.0.5/configure.ac
+--- libdca-0.0.5.orig/configure.ac 2008-06-13 23:54:27.000000000 +0200
++++ libdca-0.0.5/configure.ac 2008-06-13 23:55:58.000000000 +0200
+@@ -75,10 +75,17 @@
+ TRY_CFLAGS="$OPT_CFLAGS -xCC -fast -xO5"
+ AC_TRY_CFLAGS([$TRY_CFLAGS $CFLAGS],[OPT_CFLAGS=$TRY_CFLAGS]);;
+ esac
+ fi
+
++dnl Build tests?
++AC_ARG_ENABLE(tests,
++ AS_HELP_STRING([--disable-tests], [Don't build tests during make]),,
++ enable_tests="yes")
++AM_CONDITIONAL(TESTS, [test "$enable_tests" = "yes"])
++
++
+ # dnl Checks for libtool - this must be done after we set cflags
+ # AC_LIBTOOL_WIN32_DLL
+ m4_undefine([AC_PROG_CXX])
+ m4_defun([AC_PROG_CXX],[])
+ m4_undefine([AC_PROG_F77])
+diff -NrU5 libdca-0.0.5.orig/test/Makefile.am libdca-0.0.5/test/Makefile.am
+--- libdca-0.0.5.orig/test/Makefile.am 2008-06-13 23:54:27.000000000 +0200
++++ libdca-0.0.5/test/Makefile.am 2008-06-13 23:54:46.000000000 +0200
+@@ -1,10 +1,12 @@
++if TESTS
+ AM_CFLAGS = $(DCADEC_CFLAGS)
+
+ noinst_PROGRAMS = compare
+ compare_SOURCES = compare.c
+ compare_LDADD = $(COMPARE_LIBS)
+
+ dist_check_SCRIPTS = regression compile globals
+ EXTRA_DIST = tests
+ TESTS = regression compile
+ #broken test: globals
++endif