summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-03-09 17:54:13 +0000
committerSteve Dibb <beandog@gentoo.org>2009-03-09 17:54:13 +0000
commit35ca9f90c40448917e767e67c4f516fd12d732e9 (patch)
treef7b5cf1062efee6b7f333a5b72b130141b6e3b24 /media-libs/libdvdread/libdvdread-9999.ebuild
parentMinor fix (diff)
downloadhistorical-35ca9f90c40448917e767e67c4f516fd12d732e9.tar.gz
historical-35ca9f90c40448917e767e67c4f516fd12d732e9.tar.bz2
historical-35ca9f90c40448917e767e67c4f516fd12d732e9.zip
Add SVN snaphot, SVN ebuild
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'media-libs/libdvdread/libdvdread-9999.ebuild')
-rw-r--r--media-libs/libdvdread/libdvdread-9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/libdvdread/libdvdread-9999.ebuild b/media-libs/libdvdread/libdvdread-9999.ebuild
new file mode 100644
index 000000000000..2ef4f309044e
--- /dev/null
+++ b/media-libs/libdvdread/libdvdread-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdvdread/libdvdread-9999.ebuild,v 1.1 2009/03/09 17:54:13 beandog Exp $
+
+WANT_AUTOCONF="2.5"
+
+inherit eutils autotools multilib subversion
+
+DESCRIPTION="Library for DVD navigation tools"
+HOMEPAGE="http://mplayerhq.hu/ http://svn.mplayerhq.hu/dvdnav/trunk/libdvdread/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+ESVN_REPO_URI="svn://svn.mplayerhq.hu/dvdnav/trunk/libdvdread"
+ESVN_PROJECT="libdvdread"
+
+src_compile() {
+ ./configure2 --prefix=/usr --libdir=/usr/$(get_libdir) \
+ --shlibdir=/usr/$(get_libdir) --enable-static --enable-shared \
+ --disable-strip --disable-opts $(use_enable debug) \
+ --extra-cflags="${CFLAGS}" --extra-ldflags="${LDFLAGS}" \
+ || die "configure2 died"
+ emake version.h || die "emake version.h died"
+ emake || die "emake died"
+}
+
+src_install () {
+ emake -j1 DESTDIR="${D}" install || die "emake install died"
+ dodoc AUTHORS DEVELOPMENT-POLICY.txt ChangeLog TODO README
+}