summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-03-28 11:48:23 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-03-28 11:48:23 +0000
commita412b2e60f09bd02e7797bbb68724d1a8449369c (patch)
treec5752f930bcdf345f7ae8826e29a3e7e491acf00 /media-libs/libgphoto2/libgphoto2-2.2.1-r1.ebuild
parentia64 stable wrt bug 158626 (diff)
downloadhistorical-a412b2e60f09bd02e7797bbb68724d1a8449369c.tar.gz
historical-a412b2e60f09bd02e7797bbb68724d1a8449369c.tar.bz2
historical-a412b2e60f09bd02e7797bbb68724d1a8449369c.zip
Removed use-flag usb, now depending unconditionally on libusb, as else configure dies, thanks to armin76 for noticing.
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'media-libs/libgphoto2/libgphoto2-2.2.1-r1.ebuild')
-rw-r--r--media-libs/libgphoto2/libgphoto2-2.2.1-r1.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/media-libs/libgphoto2/libgphoto2-2.2.1-r1.ebuild b/media-libs/libgphoto2/libgphoto2-2.2.1-r1.ebuild
index 054784343d06..d679c0978274 100644
--- a/media-libs/libgphoto2/libgphoto2-2.2.1-r1.ebuild
+++ b/media-libs/libgphoto2/libgphoto2-2.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgphoto2/libgphoto2-2.2.1-r1.ebuild,v 1.20 2007/03/28 11:44:39 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgphoto2/libgphoto2-2.2.1-r1.ebuild,v 1.21 2007/03/28 11:48:23 zzam Exp $
inherit libtool eutils autotools
@@ -11,15 +11,11 @@ SRC_URI="mirror://sourceforge/gphoto/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
-IUSE="nls doc exif usb hal"
+IUSE="nls doc exif hal"
RESTRICT="test confcache"
-# needs >usbutils-0.11-r2 to avoid /usr/lib/libusb*
-# conflicts with dev-libs/libusb
-RDEPEND="usb? (
- >=dev-libs/libusb-0.1.8
- >=sys-apps/usbutils-0.11-r2
- )
+RDEPEND="
+ >=dev-libs/libusb-0.1.8
exif? ( >=media-libs/libexif-0.5.9 )
hal? ( >=sys-apps/hal-0.5 )
sys-devel/libtool"
@@ -114,7 +110,7 @@ src_install() {
dodoc ChangeLog NEWS* README AUTHORS TESTERS MAINTAINERS HACKING CHANGES
# install hotplug support
- if use usb && use kernel_linux; then
+ if use kernel_linux; then
insinto /etc/hotplug/usb
newins ${S}/packaging/linux-hotplug/usbcam.group usbcam
chmod +x ${D}/etc/hotplug/usb/usbcam
@@ -130,7 +126,7 @@ src_install() {
HAL_FDI="/usr/share/hal/fdi/information/10freedesktop/10-camera-libgphoto2.fdi"
UDEV_RULES="/etc/udev/rules.d/99-libgphoto2.rules"
- if use usb && use kernel_linux; then
+ if use kernel_linux; then
einfo "Generating usbcam-gphoto2.usermap ..."
echo "# !!! DO NOT EDIT THIS FILE !!! This file is automatically generated." > ${D}/${HOTPLUG_USERMAP}
echo "# Put your custom entries in /etc/hotplug/usb/usbcam.usermap" >> ${D}/${HOTPLUG_USERMAP}